Running as a service on Win 7 - 64bit does not work

Report and discuss bugs here!
geoced
Posts: 1
Joined: Tue Dec 20, 2011 5:42 pm

Running as a service on Win 7 - 64bit does not work

Postby geoced » Tue Dec 20, 2011 5:51 pm

Hello,

I am trying to have Yawcam run as a service but I have been unsuccessfull so far.

The program does work (locally and remotely) when I start it normally.

I have opened all necessary ports on my router and on my software firewall (Comodo). Windows firewall is turned off.

If I monitor open ports on my machine, I can see that Yawcam_Service.exe doesn't do anything when it starts (apart from checking for the lastest version). The service does not listen on any ports !

I don't know what else to try...

Any idea ?

Advertisement



kgravlin
Posts: 5
Joined: Sun Jan 08, 2012 2:16 am

Same problem Win 7 64 Yawcam does not work as a service

Postby kgravlin » Sun Jan 08, 2012 2:30 am

I am having the same problem as geoced. Win 7 64. Everything works great if I login then run Yawcam application. Service installed fine and shows up under services and starts automatically. Also doesn't work if login then start service manually however if started as service (auto or manual) then run application, application will complain that port is not available so it must be getting allocated by the service. Just doesn't open it. Anyone find the solution to this?

rigur
Posts: 5
Joined: Sun Feb 12, 2012 11:11 pm

Postby rigur » Sat Feb 18, 2012 1:10 pm

Have you checked that you have the 32 bit Java package installed?

I had a similar problem - client working with 64bit JVM but service didn't. Installing the 32bit JVM fixed the problem for me.

kgravlin
Posts: 5
Joined: Sun Jan 08, 2012 2:16 am

Postby kgravlin » Sat Feb 18, 2012 3:34 pm

No help there. Had both 32 and 64-bit Java installed. Uninstalled and reinstalled both. No change.

rigur
Posts: 5
Joined: Sun Feb 12, 2012 11:11 pm

Postby rigur » Sat Feb 18, 2012 7:44 pm

What account is your service running under - I think the service installs under the local desktop account which won't have the right permissions.

You could try changing the service to run under your account (Start->Run->services.msc), double click the Yawcam service and select the Logon tab.

Add your win account details and pw and restart the service.

kgravlin
Posts: 5
Joined: Sun Jan 08, 2012 2:16 am

Postby kgravlin » Sun Feb 19, 2012 1:28 am

The Yawcam service is running as system local (which is what just about everything else is running as). Referring back to my original post, the service IS running as attempting to run the program once logged in does tell me the port is already in use (presumably by the service. This does not occur if I set the Yawcam service to start manually and don't start it). It simply does not stream anything or respond to requests on the port.

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Postby z3r0c00l12 » Sun Feb 19, 2012 8:06 am

Then the service must be improperly configured.

There is a way of setting the service to take the config files form a specific location. Perhaps it can't find the config file right now and defaults it's settings. Try changing the port when running yawcam manually and see if the service is using the newly configured port or not.


1) Edit the file C:\Program Files\Yawcam\service_profile.cfg to contain one line like this:
C:\yawcamsettings\yawcam
2) Edit the file C:\Program Files\Yawcam\launcher.cfg
Add the word service on the last line. If it's correct the last line will end with:

Code: Select all

yawcam.Main service

kgravlin
Posts: 5
Joined: Sun Jan 08, 2012 2:16 am

Postby kgravlin » Sun Feb 19, 2012 3:13 pm

I did exactly that (and repeated it just now to confirm) and yes it allocates the new port I select in the app and still does nothing. I was never using the default port to begin with.

rigur
Posts: 5
Joined: Sun Feb 12, 2012 11:11 pm

Postby rigur » Tue Feb 21, 2012 10:31 pm

I still think it may be a permissions issue as some of the things Yawcam will do on start-up are privileged actions.

What happens if you run the service in debug mode?

First, stop the Yawcam service.

Next, start a command prompt. Unless you start by right-clicking and selecting "Run As" this will run under your logged in user's context.

Now, navigate to where Yawcam is installed, mine is under "C:\Program Files (x86)\Yawcam\"

Once there run

Code: Select all

Yawcam_Service.exe -debug
and see what complaints (if any) come up.

If none come up then the service should be running (under that user context) and you can try connecting via http etc.

If something does come up and it's not obvious then post it up.

kgravlin
Posts: 5
Joined: Sun Jan 08, 2012 2:16 am

Postby kgravlin » Sun Apr 01, 2012 7:05 pm

Win 7 64-bit problem gone! I recently upgraded to Win7 Professional and Yawcam works properly. My girlfriends machine Win7 Ultimate never showed the problem so it has something to do with Win 7 home premium 64-bit (and 32?)

timrose
Posts: 1
Joined: Thu Dec 20, 2012 4:32 pm

Opening Firewall fixes run as service

Postby timrose » Thu Dec 20, 2012 4:37 pm

When I open holes in the firewall for inbound connections on TCP and UDP 8081 having Yawcam run as a service started to work. I had to do this through the Advanced Settings dialog in the Windows 7 Firewall Control Panel. I added 2 rules to Incoming: TCP 8081 and UDP 8081. I'm running Windows 7 64 Bit Home Edition.

tentionfree
Posts: 1
Joined: Thu Jan 24, 2013 12:43 pm

Re: Running as a service on Win 7 - 64bit does not work

Postby tentionfree » Thu Jan 24, 2013 12:55 pm

Referring back to my original post, the service IS running as attempting to run the program once logged in does tell me the port is already in use by the service.


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 15 guests