yawcam crashes after ~24hrs with motion detection w/Foscam

Report and discuss bugs here!
muaddubby
Posts: 8
Joined: Wed Jan 16, 2013 12:04 pm

yawcam crashes after ~24hrs with motion detection w/Foscam

Postby muaddubby » Wed Jan 16, 2013 12:16 pm

Hi

I've been a using a wireless foscam camera (model FI8918W) for motion detection and email, and have been continually seeing yawcam crash after about 24hrs of use (regardless of motion being detected, the number of emails sent, etc).

I previously had yawcam hooked up to a webcam and never ran into this, so am suspecting it has something to do with the video stream of this particular camera. Not sure.

I tried running yawcam both as a standalone and a service; as a standalone, it just crashes. As a service, it seems to continue running, but no more emails are sent out after the 24hr boundry, and I need to restart the service.

Any ideas? I found some log files in the yawcam folder that seem to indicate a Java runtime error (EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x68382db4, pid=6932, tid=8588). Is there anyone I can email this log to? Should I post the whole thing here?

Thx!

Advertisement



malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: yawcam crashes after ~24hrs with motion detection w/Fosc

Postby malun » Sun Feb 03, 2013 1:36 pm

When you say crash... Do you mean that Yawcam stops and quit abrupt?

Could you please try to run Yawcam in java rendering mode and see if that makes any difference? This is done with the "text file hack" javarendering.txt.
More info on how to activate this here:
viewtopic.php?f=4&t=1264

It would also be helpful if you could run Yawcam in debug mode and send the log file in an email to me. Please run in debug mode until Yawcam crashes.
More info on how you create that log file here:
viewtopic.php?f=2&t=1495

/malun

muaddubby
Posts: 8
Joined: Wed Jan 16, 2013 12:04 pm

Re: yawcam crashes after ~24hrs with motion detection w/Fosc

Postby muaddubby » Mon Feb 04, 2013 1:20 am

Hi
Thx for looking into this.
Yeah, a crash in this case is defined as just shutting down abruptly when running in app mode. When running as a service I can see the service is still running, but yawcam is not doing anything after the ~24hr period. Ended up scheduling a task that restarted the service every 6hrs and it looks like this bandaid is holding. Will get your logs in the next couple of days and send them over.

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: yawcam crashes after ~24hrs with motion detection w/Fosc

Postby z3r0c00l12 » Mon Feb 04, 2013 2:20 am

Just checking, but when you say, "the service is still running", did you determine that by going in the services window, or checking that the process yawcam_service.exe was still running? I've seen cases where the service is marked as running, but the process itself is gone. When you restart the service, it starts the process again.

muaddubby
Posts: 8
Joined: Wed Jan 16, 2013 12:04 pm

Re: yawcam crashes after ~24hrs with motion detection w/Fosc

Postby muaddubby » Mon Feb 04, 2013 3:21 am

sorry I wasn't clear. I meant that the service was still running. I did not check to see if the yawcam process was still running. Do you want to try again and check ?

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: yawcam crashes after ~24hrs with motion detection w/Fosc

Postby z3r0c00l12 » Mon Feb 04, 2013 5:37 am

Most people don't know this, that's why I asked, so don't worry about it. If you have the chance next time, please check the process.

muaddubby
Posts: 8
Joined: Wed Jan 16, 2013 12:04 pm

Re: yawcam crashes after ~24hrs with motion detection w/Fosc

Postby muaddubby » Wed Feb 06, 2013 4:01 am

Running with the debug logs and the java rendering now. Will send you results as soon as it crashes.

malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: yawcam crashes after ~24hrs with motion detection w/Fosc

Postby malun » Wed Feb 06, 2013 8:53 pm

Perfect. Thanks!

/malun

muaddubby
Posts: 8
Joined: Wed Jan 16, 2013 12:04 pm

Re: yawcam crashes after ~24hrs with motion detection w/Fosc

Postby muaddubby » Thu Feb 07, 2013 11:46 am

Hi Malun

I ran yawcam in debug mode (with Java rendering), and the effect was a bit different this time. Yawcam did not shutdown and just kept on running, but the image in the preview window froze after about 15 hours, and no more motion detection events occurred after that point (i.e. no more motion detection snapshots saved to the drive and no more email alerts sent). In the debug log, about 20 lines from the end, there's a Java "out of memory" error.

I can email the log to you, but the messaging system on the board does not appear to support attachments. Looks like I can only add the attachment to this post, and I'd rather not make it available to the greater public. Do you want a regular email? If so, what address do I send it to? Maybe send me a private message with the address?

thx.

malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: yawcam crashes after ~24hrs with motion detection w/Fosc

Postby malun » Thu Feb 07, 2013 10:15 pm

It would be great if you could attach the debug file in an email to me at: malun@yawcam.com

/malun

muaddubby
Posts: 8
Joined: Wed Jan 16, 2013 12:04 pm

Re: yawcam crashes after ~24hrs with motion detection w/Fosc

Postby muaddubby » Thu Feb 07, 2013 10:40 pm

Done :)

malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: yawcam crashes after ~24hrs with motion detection w/Fosc

Postby malun » Fri Feb 22, 2013 12:48 am

Just to let everyone else know (if you follow or find this thread later):
Looks like problem solved with a combination of java rendering mode and the new release 0.4.0 of Yawcam.

/malun


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 13 guests