Debug_Start issue

Report and discuss bugs here!
z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Debug_Start issue

Postby z3r0c00l12 » Tue Feb 19, 2013 4:51 am

I found a small problem, in v0.3.9, perhaps it should be looked into. When I tried to launch debug_start, I got an error in the log saying "java.exe" couldn't be found.

I know Java is installed, but only the x86 version, even though it's an x64 operating system.

Knowing why this would occur, I launched cmd from C:\Windows\SYSWOW64\, then launched the debug_start batch file, which launched Yawcam successfully. When I investigated the logs, the OS Architecture was marked as x86 even though it's x64.

Windows 7 Home Premium x64
Java 7.13 x86
Java x64 not installed

So my point is:
1) If only x86 java is installed on an x64 OS, the debug batch file should launch the x86 java, not stop with "java.exe" not found.
2) The debug should be able to identify an x64 system even when running with java x86.

Advertisement



malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: Debug_Start issue

Postby malun » Fri Feb 22, 2013 1:04 am

The debug batch file (as well as the ordinary start file for Yawcam) is just calling for javaw.exe.
The javaw.exe that is the first one found on the computer's PATH is used.

Did you have java on the path?
What output did you get if you typed "java -version" in an command window?

/malun

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Debug_Start issue

Postby z3r0c00l12 » Fri Feb 22, 2013 4:09 am

I'll have to ask boom_243 since the debug was from his computer.

I just had a look on my system though and there are no references to java in my path.

I checked using "echo %path%". Note that I tried using both the 32-bit and the 64-bit command prompt, which produced different results.

I also tried "java -version", which returned:

Code: Select all

java version "1.7.0_13"
Java(TM) SE Runtime Environment (build 1.7.0_13-b20)
Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 16 guests