Wrong order of lines in image

Report and discuss bugs here!
daniel.kukiela
Posts: 5
Joined: Fri Apr 19, 2013 5:53 pm

Wrong order of lines in image

Postby daniel.kukiela » Fri Apr 19, 2013 6:07 pm

Hi.

I have a problem with Yawcam and motion detection.
Sometimes captured frame has wrong order of some lines, what triggers motion detection. Wrong order of lines can be seen in motion detection window and in captured frame (file on disk), but not in preview window.
Problem occurs also of my friends computer with different hardware and different camera.
With this bug Yawcam reports false motion detections making this function unusable.

Is tehere something i can do to fix it?


Daniel

Advertisement



z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Wrong order of lines in image

Postby z3r0c00l12 » Fri Apr 19, 2013 10:48 pm

What version of Yawcam are you using?

Can you post some images as examples of the problem?

daniel.kukiela
Posts: 5
Joined: Fri Apr 19, 2013 5:53 pm

Re: Wrong order of lines in image

Postby daniel.kukiela » Sat Apr 20, 2013 2:41 pm

Yawcam version: 0.4.0
Java version: 1.7.0_09
Example image in attachment (zipped, i don't want Google to index it).
I can take more examples if you want to.


Thanks.
Daniel
Attachments
motion_2013-04-20_08.28.19_566.zip
(53.38 KiB) Downloaded 411 times

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Wrong order of lines in image

Postby z3r0c00l12 » Sat Apr 20, 2013 4:25 pm

That's the first time I see such an issue. My 2 assumptions are either the camera is defective or it's a bug with Yawcam. With the picture here, Malun will be able to investigate further, but it will take a bit longer.

daniel.kukiela
Posts: 5
Joined: Fri Apr 19, 2013 5:53 pm

Re: Wrong order of lines in image

Postby daniel.kukiela » Sat Apr 20, 2013 4:49 pm

I also thought that problem is in my hardware, but it occurs on two of my computers with this cameras (i have two identical cameras) and on my friend's set (with other computer hardware and other camera manufacturer and model).
What's more, i do not see artefacts in prewiew window even when "Motion Detection" detects false motion because of that problem (and frame, like attached above, is saved on disk).
It looks like problem with frame processing in Yawcam (maby by bug in Java?).

Let me know if i can help (e.g. attach more pictures).


Thanks.
Daniel

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Wrong order of lines in image

Postby z3r0c00l12 » Sat Apr 20, 2013 6:22 pm

If you want, you can try to update to Yawcam 0.4.1.

If you update Java to 7u21, you'll need Yawcam 0.4.1 as Yawcam 0.4.0 only works with Java 7 up to update 20.

daniel.kukiela
Posts: 5
Joined: Fri Apr 19, 2013 5:53 pm

Re: Wrong order of lines in image

Postby daniel.kukiela » Sun Apr 21, 2013 11:17 pm

Yawcam version: 0.4.1
Java version: 1.7.0_21
Problem still exists...

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Wrong order of lines in image

Postby z3r0c00l12 » Sun Apr 28, 2013 7:12 pm

Can you try going in the camera's settings and restoring the settings to default?

daniel.kukiela
Posts: 5
Joined: Fri Apr 19, 2013 5:53 pm

Re: Wrong order of lines in image

Postby daniel.kukiela » Tue Apr 30, 2013 9:45 pm

It's on defaults (only resolution in Yawcam is changed from 320x240 to 640x480).


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest