Yawcam not starting with Java ver 8 update 25 me too

Report and discuss bugs here!
Snowman
Posts: 8
Joined: Thu Oct 25, 2012 7:23 pm

Yawcam not starting with Java ver 8 update 25 me too

Postby Snowman » Wed Nov 26, 2014 10:26 pm

I am experiencing the same problem as others in that Yawcam will not startup. I have not located any fix, only the workaround to start it in
debug_start.bat. Hopefully someone will get a fix for this. Can't believe there aren't more people reporting this.

Advertisement



StevenS
Posts: 1
Joined: Mon Dec 01, 2014 1:16 pm

Re: Yawcam not starting with Java ver 8 update 25 me too

Postby StevenS » Mon Dec 01, 2014 1:54 pm

Found the Solution (Finally)

Problem:
YamCam cannot find the Java Binary after installing Java 8-25. Attempting to start Yamcam resulted in "Could not start application" window.

Description:
During Java installation, Java places a PATH variable to java, which is actually a shortcut to the actual binary. In my case, the Java installation added: "C:\ProgramData\Oracle\Java\javapath" to the environment variable which points to a shortcut to Java (as well as Javaw and Javaws). Yamcam apparently does not like being pointed to a shortcut to java.

Solution:
I changed the environment variable to "C:\Program Files (x86)\Java\jre1.8.0_25\bin" which is the location of the actual Java binary. While this is not a perfect solution, since the path will probably change in the next release of java, it is better than having an outdated version of Java on the system. Maybe in a future release of YamCam it will not mind being directed to a shortcut to Java (hint, hint...)

Credit:
The following post led me to this solution:
viewtopic.php?f=4&t=3477
(Thank you Malun)

And thank you YamCam for being a great application!



I had another problem that you might also experience. When I entered the "path" command at a CMD prompt, it did not reflect what was set in the path environment variable. I found that if I placed the new variable in front of the existing "%SystemRoot%\system32;" entry - it was not seen. No idea why that should happen. I placed the new path to the java binary at the end and it worked fine.
Remember that the path environment variable will only update after you log off and back on.
I am currently running on Windows 7 Ultimate SP1, but this solution should be appropriate for any flavor of Windows 7 or 8.

If you are unsure as to how to change the PATH environment variable, look at step 5 in the above mentioned post, or check out:
https://www.java.com/en/download/help/path.xml
http://www.computerhope.com/issues/ch000549.htm



Steven


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest