Windows 10 Yawcam won't start

Report and discuss bugs here!
jburger
Posts: 4
Joined: Wed Aug 05, 2015 3:49 pm

Windows 10 Yawcam won't start

Postby jburger » Wed Aug 05, 2015 3:57 pm

Has anyone else ran into this yet? I upgraded one of my pc's to Windows 10, now yawcam won't start. If I try to just start the service, I get the error below....

C:\Program Files\Yawcam>NET START "Yawcam"
The service name is invalid.

More help is available by typing NET HELPMSG 2185.


*********************
*** ERROR ***
*********************

Press any key to continue . . .

But I can't type NET HELPMSG 2185, because the screen closes as soon as you hit any key. Any ideas?

Advertisement



z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Windows 10 Yawcam won't start

Postby z3r0c00l12 » Sat Aug 08, 2015 12:20 am

Can you make sure Yawcam is still installed? Maybe Windows 10 didn't carry it forward.

If it's still installed, try running the Install Service again.

My guess is you have to re-install Yawcam, re-install the service and most likely re-configure Yawcam as the settings might not be there anymore.

jburger
Posts: 4
Joined: Wed Aug 05, 2015 3:49 pm

Re: Windows 10 Yawcam won't start

Postby jburger » Sat Aug 08, 2015 12:34 am

Yes I have tried that, but I can try again in a little while. Has anyone successfully got it to run on Windows 10?
Last edited by jburger on Mon Aug 10, 2015 5:49 pm, edited 1 time in total.

MA_Angel
Posts: 37
Joined: Mon Jul 20, 2015 12:35 pm

Re: Windows 10 Yawcam won't start

Postby MA_Angel » Sat Aug 08, 2015 4:17 am

Fresh install of Java (build 1.8.0_51-b16), then fresh install of Yawcam (v0.4.2), and all seem working for me on a Win10 Pro x64 laptop with both its internal webcam and a Logitech C910 webcam.

jburger
Posts: 4
Joined: Wed Aug 05, 2015 3:49 pm

Re: Windows 10 Yawcam won't start

Postby jburger » Mon Aug 10, 2015 5:49 pm

Tried uninstalling and reinstalling both programs with no luck. So I uninstalled them again, and deleted their install folders (hoping to ensure a fresh install). That didn't work either. I'm running out of ideas to try.

aerfalle
Posts: 1
Joined: Mon Aug 10, 2015 8:51 pm

Re: Windows 10 Yawcam won't start

Postby aerfalle » Mon Aug 10, 2015 8:53 pm

I too am having this issue after upgrading from Windows 8 where it worked ok. I have reinstalled to the latest java and version of yawcam without any luck.

The service starts on my pc however doesn't actually do anything. Restarting the service fixes it but that isn't ideal as want to run it without having to log on.

MA_Angel
Posts: 37
Joined: Mon Jul 20, 2015 12:35 pm

Re: Windows 10 Yawcam won't start

Postby MA_Angel » Tue Aug 11, 2015 3:28 am

Does Yawcam start up normally? Not obvious from your posts, but did you fresh install the service too (running the batch file as Admin)? Also note that the default path is C:\Program Files (x86)\Yawcam

jburger
Posts: 4
Joined: Wed Aug 05, 2015 3:49 pm

Re: Windows 10 Yawcam won't start

Postby jburger » Wed Aug 12, 2015 1:07 am

Yawcam appears to start, but it never does. I did install the service using admin credentials, and it installed ok. After doing that, when I run the debug program I get this error now....

"Error: Could not find or load main class yawcam.Main"

From extensive searching, I think the problem lies in the registry, but I don't know where or what to repair/replace in it.

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Windows 10 Yawcam won't start

Postby z3r0c00l12 » Sun Aug 16, 2015 6:15 pm

Yawcam doesn't rely on any registry keys that I can think of.

It really only relies on the file location and that Java is properly installed.

Click on Start, in the search box, type "cmd" without the quotes.
When you see cmd.exe show up, press Ctrl+Shift+Enter or right-click on cmd.exe and select Run As Administrator
If you get a UAC prompt, click yes or log in with an account having admin rights.
Once the command prompt opens, confirm that the window name starts with "Administrator: ", this confirms it's running with administrative privileges.
At the command prompt, type "java -version" without the quotes and press enter.
If you get an error, than either Java is not installed, it didn't install properly or the path to Java didn't register properly.

sumri
Posts: 1
Joined: Thu Aug 20, 2015 1:38 am

Re: Windows 10 Yawcam won't start

Postby sumri » Thu Aug 20, 2015 1:43 am

Yawcam would not open after I upgraded to Win 10 64 and Java is also loaded. I have a USB webcam so I unplugged it from the USB port and Yawcam loaded. I plugged the webcam back in and selected the camera and Yawcam works. Only problem, you have to do this each time you load Yawcam.

MattMan
Posts: 3
Joined: Fri Aug 28, 2015 5:02 pm

Re: Windows 10 Yawcam won't start

Postby MattMan » Wed Sep 02, 2015 3:39 am

I get this in the log file located inside yawcam folder.

# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x19eb4a80, pid=5132, tid=2536
#
# JRE version: Java(TM) SE Runtime Environment (8.0_60-b27) (build 1.8.0_60-b27)
# Java VM: Java HotSpot(TM) Client VM (25.60-b23 mixed mode, sharing windows-x86 )
# Problematic frame:
# C [dsj.dll+0x14a80]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows

My java -version
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) Client VM (build 25.60-b23, mixed mode, sharing)

MA_Angel
Posts: 37
Joined: Mon Jul 20, 2015 12:35 pm

Re: Windows 10 Yawcam won't start

Postby MA_Angel » Fri Sep 04, 2015 1:15 pm

@sumri,
Did you try I uninstalling Yawcam and Java completely, and then doing fresh installs with the latest versions?
Also, try uninstalling the webcam drivers and let it re-install automatically...

@MattMan,
Sure you're using the right version of Java and not mixing x86 and x64 versions or have multiple versions of Java installed?

MattMan
Posts: 3
Joined: Fri Aug 28, 2015 5:02 pm

Re: Windows 10 Yawcam won't start

Postby MattMan » Sun Sep 06, 2015 4:33 am

MA_Angel wrote:@MattMan,
Sure you're using the right version of Java and not mixing x86 and x64 versions or have multiple versions of Java installed?


As far as I can tell I'm using x86 since Java is installed in the program files(x86) folder.

YawCam was one of the first things I installed after I installed Windows 10. Here is basically what I did.

1. Clean Install of Windows 10pro 64bit
2. Downloaded YawCam tried to install, but it told me to get Java.
3. Pretty sure YawCam directed me to the Java download page if I remember right.
4. Installed Java.
5. YawCam no workie

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Windows 10 Yawcam won't start

Postby z3r0c00l12 » Thu Sep 10, 2015 10:44 pm

Have you tried this?

viewtopic.php?f=4&t=3477

JonPeyton
Posts: 1
Joined: Wed Oct 28, 2015 5:10 am

Re: Windows 10 Yawcam won't start

Postby JonPeyton » Wed Oct 28, 2015 5:12 am

Im on Windows 10.
Im running FOUR instances of Yawcam right now , with no issues

I plan to donate on payday.Thanks for this wonderful application.
JP


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 2 guests