Windows 8.1 YAWCam Crashes When Loading Camera

Report and discuss bugs here!
ShibSta
Posts: 2
Joined: Sat Sep 26, 2015 8:20 am

Windows 8.1 YAWCam Crashes When Loading Camera

Postby ShibSta » Sat Sep 26, 2015 8:25 am

I have a Logitech C910 camera. When I disable the device in the device manager, YAWCam loads the GUI fine. However, when I enable it, YAWCam crashes during the splash screen while 'loading devices...'

Code: Select all

Running init for cam: 0 pin: 0 format: 0
CamManager.initCam()
dsj.dll version: 0_8_7
dsj.jar version: 0_8_7
DSEnvironment.getSystemInfo(true):
OS: Windows 8.1, 6.3, x86
JRE: 1.8.0_60, class version: 52.0
Locale: en_US, codepage: Cp1252

java home: C:\Program Files (x86)\Java\jre1.8.0_60

class path: .;lib/activation.jar;lib/commons-jxpath-1.1.jar;lib/commons-logging.jar;lib/commons-logging-api.jar;lib/dsj.jar;lib/jmf.jar;lib/mail.jar;lib/mx4j-impl.jar;lib/mx4j-jmx.jar;lib/mx4j-remote.jar;lib/mx4j-tools.jar;lib/sbbi-jmx-1.0.jar;lib/sbbi-upnplib-1.0.4.jar;lib/ftp4j.jar;lib/commons-codec-1.4.jar

library path: C:\ProgramData\Oracle\Java\javapath;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Python27\;C:\Python27\Scripts;C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\HashiCorp\Vagrant\bin;C:\Program Files (x86)\Git\cmd;C:\Program Files (x86)\nodejs\;C:\Users\Devon\AppData\Roaming\php;C:\ProgramData\ComposerSetup\bin;C:\Program Files (x86)\Skype\Phone\;C:\Users\Devon\AppData\Roaming\npm;.
CamManager.queryDevices()
F: http://www.yawcam.com/ver.dat
F: http://home.bitcom.se/yawcam_files/ver.dat
0.4.2 == 0.4.2  -> 0
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x61014a80, pid=3616, tid=9264
#
# JRE version: Java(TM) SE Runtime Environment (8.0_60-b27) (build 1.8.0_60-b27)
# Java VM: Java HotSpot(TM) Client VM (25.60-b23 mixed mode, sharing windows-x86 )
# Problematic frame:
# C  [dsj.dll+0x14a80]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# An error report file with more information is saved as:
# C:\Users\Devon\AppData\Local\Temp\\hs_err_pid3616.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#


Also, just our of curiosity, since this program is free and doesn't seem like development is very active, would you consider making it open-source on GitHub or something? That way, others would be able to continue your work and perhaps make it a bit more stable...

Thanks

Advertisement



z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Windows 8.1 YAWCam Crashes When Loading Camera

Postby z3r0c00l12 » Sat Sep 26, 2015 3:01 pm

Looks like you are getting an access violation. Try running Yawcam as an administrator, that fixed that problem for me before.

ShibSta
Posts: 2
Joined: Sat Sep 26, 2015 8:20 am

Re: Windows 8.1 YAWCam Crashes When Loading Camera

Postby ShibSta » Sun Sep 27, 2015 4:02 am

I've already tried that, that was the first thing I tried, right after closing Skype and everything else that may have been using the camera.

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Windows 8.1 YAWCam Crashes When Loading Camera

Postby z3r0c00l12 » Sun Sep 27, 2015 4:14 am

Try uninstalling the drivers (if any), reinstall latest drivers (from logitech's website), restart your computer then run Yawcam as and administrator.


Return to “Bugs”

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest