Yawcam becoming unresponsive overnight

Report and discuss bugs here!
ehud42
Posts: 9
Joined: Mon Mar 14, 2016 3:23 pm

Yawcam becoming unresponsive overnight

Postby ehud42 » Mon Mar 14, 2016 3:37 pm

I'm running Win7, and I have Yawcam configured to grab an image and ftp to a site every minute.

Very consistently, around 1:30AM it stops responding.

The console seems responsive (I can open different menus, etc), however, the preview is black.
If I disconnect the camera, it notes the lack of camera, but won't detect/resume if I plug it back in.
If I try to close Yawcam, it gets to the "Good bye" dialogue and hangs there - I have to kill it via task manager.
If helpful, I can post debug files from the last few nights.

Advertisement



malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: Yawcam becoming unresponsive overnight

Postby malun » Mon Mar 14, 2016 8:16 pm

Yes, please. A debug file would be nice!

/malun

ehud42
Posts: 9
Joined: Mon Mar 14, 2016 3:23 pm

Re: Yawcam becoming unresponsive overnight

Postby ehud42 » Tue Mar 15, 2016 1:48 am

Attached is a zip of 4 debug files. 3 ended between 01:30 & 01:45 and one at 21:37.

I have another debug session running right now - as noted in a related post I have (without restarting) turned off the device monitor.

I'm grabbing a frame once / minute (and ftp'ing to my site).
Attachments
Desktop.zip
(28.54 KiB) Downloaded 189 times

ehud42
Posts: 9
Joined: Mon Mar 14, 2016 3:23 pm

Re: Yawcam becoming unresponsive overnight

Postby ehud42 » Tue Mar 15, 2016 1:35 pm

Well, it kept running through the night - will see how long it keeps going!

ehud42
Posts: 9
Joined: Mon Mar 14, 2016 3:23 pm

Re: Yawcam becoming unresponsive overnight

Postby ehud42 » Thu Mar 17, 2016 1:41 pm

It ran fine for long time, so I tried turning on the device monitoring.

Within an hour or so of re-enabling the "Enable device error monitor" it locked up and required a taskmanager kill to go away.

Running again without error monitoring.

malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: Yawcam becoming unresponsive overnight

Postby malun » Thu Mar 17, 2016 11:37 pm

Thanks for the log files!

As you have noticed they look very similar to glires' logs in this thread:
viewtopic.php?f=2&t=4665

Interesting that you don't get the lock up when running with the device monitor disabled.
My guess is though that you occasionally get either black images or images without change now when you are running with the device monitor disabled. Is this something that you can confirm?
Also, do you have a log file from when you are running with the device monitor disabled?

Another thing I would appreciate if you could try is this:

Enable the device monitor again. This time, make sure that the preview window is open in Yawcam all the time when you are running. If you want you can minimize the preview window, but don't close it. This should force the camera to be active all the time so it won't be paused between the ftp uploads. And again, please run in debug mode so that we can check the logs if needed.

/malun

ehud42
Posts: 9
Joined: Mon Mar 14, 2016 3:23 pm

Re: Yawcam becoming unresponsive overnight

Postby ehud42 » Fri Mar 18, 2016 1:21 am

Well, it locks up at night, and unless the kids are up and around, the target area is quite dark - effectively black.

I have re-enabled the device monitor, and opened the preview window. I uploaded the current log file as it was with the device monitor disabled since this morning.
Attachments
yawcam_debug_log-good.zip
(4.91 KiB) Downloaded 147 times

ehud42
Posts: 9
Joined: Mon Mar 14, 2016 3:23 pm

Re: Yawcam becoming unresponsive overnight

Postby ehud42 » Fri Mar 18, 2016 3:58 pm

Well, I checked on it this morning, and it died shortly after I turn the light off last night. (Preview was open and black. When I tried to redetect the camera, the preview changed to a device not attached message, and then the main window stopped responding. Had to kill the Java process).

I restarted it this morning with the device monitor disabled.

malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: Yawcam becoming unresponsive overnight

Postby malun » Sat Mar 19, 2016 1:29 pm

Thanks!

I would appreciate if you also could provide a log file from when you run with device monitor enabled and the preview window open.
Another thing... what camera are you using? Brand and model?

/malun

ehud42
Posts: 9
Joined: Mon Mar 14, 2016 3:23 pm

Re: Yawcam becoming unresponsive overnight

Postby ehud42 » Sat Mar 19, 2016 11:18 pm

I will try to post log file tomorrow.

Camera is a generic web cam. Nexxtech model 2516523E

ehud42
Posts: 9
Joined: Mon Mar 14, 2016 3:23 pm

Re: Yawcam becoming unresponsive overnight

Postby ehud42 » Sun Mar 20, 2016 2:50 pm

Preview window was open and device error enabled. It made it past the previous ~1:30AM, but then locked up just before 3AM.

Last image uploaded was not black (see attached). Also attached debug log as requested.
Attachments
out.jpg
out.jpg (21.27 KiB) Viewed 7930 times
yawcam_debug_log.zip
(6.18 KiB) Downloaded 148 times

malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: Yawcam becoming unresponsive overnight

Postby malun » Tue Mar 22, 2016 12:16 am

Thanks for the files!
I'll see if they can help me figure out what's going on...

And as always, some more questions:
In your first post, you say that the preview window goes black.
When this happens, is the preview pitch black or black with some "natural" noise?

The reason I ask is that some cameras (and their driver) will detect when the image is almost completely dark. Instead of delivering a black image with some natural noise caught by the camera sensor, it will deliver a pitch black image created by the camera driver without noise.
The device error monitor in Yawcam will never work with a camera that delivers images without natural noise during the night. That's why it's possible do disable the device error monitor, so Yawcam can work also with these cameras.

Anyway, even if your camera is a "no noise" camera or not, Yawcam shouldn't freeze and stop responding...
It looks like something isn't working as intended.

/malun

ehud42
Posts: 9
Joined: Mon Mar 14, 2016 3:23 pm

Re: Yawcam becoming unresponsive overnight

Postby ehud42 » Tue Mar 22, 2016 12:52 am

Initial tests were a result of lockups overnight. Sorry, I get what you're asking, but I no longer have those images. They were dark, and I was suspecting maybe too dark/still for the detection software. There have been cases where the software has locked up with lit images, and so I think the dark image theory is no longer supported.

malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: Yawcam becoming unresponsive overnight

Postby malun » Sun Mar 27, 2016 3:24 pm

I found a scenario where the device error monitor could lock up Yawcam. I was able to reproduce the problem on one of my test machines and made a fix for it. But my logs differs a bit from your logs, so I'm not entirely sure that this will fix the problem for you...

But it would be great if you could try this new beta version that contains a fix. :D
Please use this version of Yawcam:
yawcam_BETA_2016-03-27.exe

and run it in debug mode with the device error monitor enabled.
Do you get a different behavior?

/malun

jxoco
Posts: 40
Joined: Sat Mar 26, 2011 8:50 pm

Re: Yawcam becoming unresponsive overnight

Postby jxoco » Mon Mar 28, 2016 9:44 pm

I've started using the beta so we'll see how it goes for me but just reading your post I thought I would add a comment as well.
I have the same 'won't work for 24 hours thing' with version 5 but for quite some time I've have the same cameras and at nite they do go to pitch back.
One camera is on the furnace looking into the burning chamber and it is pitch black for weeks, and all summer. Version 4.2 coped fine.

We'll see how the beta works out..


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest