Wierd lines triger motion recording

Report and discuss bugs here!
Windows10User
Posts: 1
Joined: Wed Jun 08, 2016 10:34 pm

Wierd lines triger motion recording

Postby Windows10User » Wed Jun 08, 2016 10:40 pm

I am under 0.6.0 and when I review recorded footage from YawCam there are strange lines flashing in the recording, I am running Windows 10

Advertisement



tumarije
Posts: 4
Joined: Sat Jan 07, 2017 5:44 pm

Re: Wierd lines triger motion recording

Postby tumarije » Sun Jan 08, 2017 7:31 pm

Hello!

Is this what you ment? Those lines are not present when I checked online 1 to 1 (left to right) with direct web connection to the camera, but on motion detection picture they were. I checked over several appearances. In my case they appear from 1 to 3 or 4 at the time, their appearance is very sporadical, sometimes there is 5 or more minutes without them but sometimes they appear 5 seconds appart.

It could be some glitch in the motion detection algorithm or rather in the Reference image algorithm - I use this great feature. It appear in both cases: with and without Auto level. But I am not sure if they also appear in the Frame-to-frame mode.

For me they present no problem. :D
Attachments
Motion detection.PNG
Sporadically appearing lines in the Motion detection
Motion detection.PNG (177.56 KiB) Viewed 48525 times

nikho06
Posts: 1
Joined: Wed Apr 19, 2017 11:10 am

Re: Wierd lines triger motion recording

Postby nikho06 » Wed Apr 19, 2017 11:18 am

I have the same problem, randomly triggering motion detection; it happens maybe 30 times a day; running a low-cost asus Eeee PC 1005 PE, Windows 7 starter ed. with all updates applied, and drivers up-to-date, yawcam 0.6, I wonder if it has to do with the PC's specs not high enough ?
Here is a sample:

motion_2017-04-19-09.22.44_919.jpg
motion_2017-04-19-09.22.44_919.jpg (54.54 KiB) Viewed 48160 times

rmzalbar
Posts: 1
Joined: Sat Jul 15, 2017 2:14 am

Re: Wierd lines triger motion recording

Postby rmzalbar » Sat Jul 15, 2017 2:28 am

I was beating my head against the wall trying to decide if it was my camera, my USB port, or drivers that were broken. This is exactly what I have been getting!

1. These are single-frame glitches that appear to be randomly spaced anywhere from a few seconds to a few minutes apart.

2. They are visible in motion detection, motion detection settings view, AND in stream broadcast, but NOT in the preview window.

3. These only occur when motion detection is ACTIVE, or when the motion detection settings preview is open.

Windows 7
CPU: I7-2600
Cam: Logitech C920, plugged into USB 3.0 port
Format: RGB24 15fps 800x600


motion_set.png
motion_set.png (177.04 KiB) Viewed 2641 times

motion_2017-07-14_13.55.25_740.jpg
motion_2017-07-14_13.55.25_740.jpg (69.47 KiB) Viewed 2641 times

ChristopherKris
Posts: 1
Joined: Wed Nov 22, 2017 8:54 am

Re: Wierd lines triger motion recording

Postby ChristopherKris » Wed Nov 22, 2017 8:56 am

So....whats its solution????

RideZ
Posts: 1
Joined: Sun Mar 25, 2018 6:15 pm

Re: Wierd lines triger motion recording

Postby RideZ » Sun Mar 25, 2018 6:40 pm

I am having the same problem here but, it only occurs when i flip horizontal setting. The camera is mounted upside down!

running an older compaq laptop, Win7, gear head hd webcam

sensormonkey
Posts: 3
Joined: Tue Mar 27, 2018 4:07 pm

Re: Wierd lines triger motion recording

Postby sensormonkey » Tue Mar 27, 2018 4:18 pm

these issues (the horizontal lines anyway) look like artifacts from either image formation or readout - lines of detector data being duplicated in spatially incorrect locations. It could be any number of things from the way the camera manufacturer reads off and arranges the data to how the image is written into memory. the vertical lines could be a similar issue but it could also be a different focal plane related issue, I don't really know. Ultimately, there's not likely an easy way to "fix" the camera but as a processing step you could add a filter in that sets a temporal threshold for motion - in order to trigger an event motion must be detected above the set % and also for a specific number of frames or seconds. That should alleviate most of these issues as they seems to be very short temporal instances. I have them also from 2 logitec C930e cameras. From what I've seen I could easily filter out any and all events that do not result in sustained movement for at least a half second to 1 second.

sensormonkey
Posts: 3
Joined: Tue Mar 27, 2018 4:07 pm

Re: Wierd lines triger motion recording

Postby sensormonkey » Tue Mar 27, 2018 5:46 pm

*TLDR add a temporal filter - motion above detection threshold must persist for a least X seconds or X frames


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest