no TrayIcon12 in java.library.path

Report and discuss bugs here!
agiltinan
Posts: 1
Joined: Wed Jul 13, 2016 4:49 pm

no TrayIcon12 in java.library.path

Postby agiltinan » Wed Jul 13, 2016 4:59 pm

Hi,

I know this topic arose before but i now have the same issue. I tried the recommendations in the other thread but no luck.

my debug info is here:
YAWCAM - Yet Another Webcam Software
Version: 0.6.0 (2016-05-11)
os.arch: x86
java.home: C:\Program Files\Java\jre1.8.0_91
java.vendor: Oracle Corporation
java.version: 1.8.0_91
java.io.tmpdir: C:\Users\DISH\AppData\Local\Temp\
user.home: C:\Users\DISH
Max heap memory: 247M
base_path: C:\Users\DISH\.yawcam\
File.separator: \
Local language: en
Time zone: sun.util.calendar.ZoneInfo[id="Europe/London",offset=0,dstSavings=3600000,useDaylight=true,transitions=242,lastRule=java.util.SimpleTimeZone[id=Europe/London,offset=0,dstSavings=3600000,useDaylight=true,startYear=0,startMode=2,startMonth=2,startDay=-1,startDayOfWeek=1,startTime=3600000,startTimeMode=2,endMode=2,endMonth=9,endDay=-1,endDayOfWeek=1,endTime=3600000,endTimeMode=2]]
copyFilesToUserDir()
Reading settings: C:\Users\DISH\.yawcam\yawcam_settings.xml
CompatibleImageType: TYPE_INT_RGB (1)
Checking lock file: C:\Users\DISH\.yawcam\yawcam-1.lck
ApplicationInstanceLock: I got ID: 1
Resolving public IP.
url 0 : http://www.yawcam.com/ver.dat
url 1 : http://home.bitcom.se/yawcam_files/ver.dat
Using ip check url: http://www.yawcam.com/ipq.php
Passwords:
---------------------------------
---------------------------------
Banned ip:
---------------------------------
---------------------------------
Running init for cam: 3, pin: 0, format: 0
CamManager.initCam()
dsj.dll version: 0_8_7
dsj.jar version: 0_8_7
DSEnvironment.getSystemInfo(true):
OS: Windows 7, 6.1, x86
JRE: 1.8.0_91, class version: 52.0
Locale: en_US, codepage: Cp1252

java home: C:\Program Files\Java\jre1.8.0_91

class path: .;lib/activation.jar;lib/commons-jxpath-1.1.jar;lib/commons-logging.jar;lib/commons-logging-api.jar;lib/dsj.jar;lib/monte-cc.jar;lib/mail.jar;lib/mx4j-impl.jar;lib/mx4j-jmx.jar;lib/mx4j-remote.jar;lib/mx4j-tools.jar;lib/sbbi-jmx-1.0.jar;lib/sbbi-upnplib-1.0.4.jar;lib/ftp4j.jar;lib/commons-codec-1.4.jar;lib/turbojpeg.jar

library path: C:\ProgramData\Oracle\Java\javapath;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\QuickTime\QTSystem\;.
CamManager.queryDevices()
157.190.240.20
F: http://www.yawcam.com/ver.dat
F: http://home.bitcom.se/yawcam_files/ver.dat
0.6.0 == 0.6.0 -> 0
Devices:
[0]: Ip Camera
[0]: Ip Camera
[1]: SplitCam Video Driver
[1]: \\?\root#media#0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\global
[2]: Conexant Polaris Video Capture
[2]: \\?\usb#vid_1f4d&pid_0102&mi_01#7&31956d8d&0&0001#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\{9b365890-165f-11d0-a195-0020afd156e4}
[3]: SplitCam Video Capture
[3]: SplitCam Video Capture
[4]: none
[4]: none
Audio Devices:
[0]: Stereo Mix (Conexant HD Audio)
[0]: \\?\hdaudio#func_01&ven_14f1&dev_50a1&subsys_102804f5&rev_1001#4&26fc5984&0&0201#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\stereomixwave
[1]: Analog Audio In (USB2.0 Video C
[1]: \\?\usb#vid_1f4d&pid_0102&mi_01#7&31956d8d&0&0001#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\{5eaf914d-2212-4034-8c4c-02cafd15d68a}
[2]: Microphone (SplitCam Virtual Au
[2]: \\?\root#media#0001#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\wave
[3]: none
[3]: none
Some devices are not available at present:
IP Split Camera
INIT CAMERA, SwingUtilities.isEventDispatchThread():false
Forcing:
cam=3
pin=0
format=0
..----------------
Initialized:
video: RGB24
width: 512, height: 384
bitDepth: 24
frameRate: 5.0
duration: 0ms (00:00:00)
----------------
#### Trying RENDERMODE: NATIVE
### RENDERMODE OK! ###
RENDERMODE: NATIVE
CamManager.initCam() is calling pause()
pausing cam
Started DeviceMonitor
#######################
Audio output devices:
Primary Sound Driver
Speakers (Conexant HD Audio)
Speakers (SplitCam Virtual Audio Device (WDM))
#######################
Could not load C:\Users\DISH\.yawcam\motion\EventList.bin
(Will create a new one when needed...)
Building device menu right now!
Building 'Change to'-menu...
Exception in thread "main" java.lang.UnsatisfiedLinkError: no TrayIcon12 in java.library.path
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at com.jeans.trayicon.WindowsTrayIcon.<clinit>(WindowsTrayIcon.java:691)
at yawcam.gui.TrayIconManager.<init>(TrayIconManager.java:79)
at yawcam.Main.<init>(Main.java:442)
at yawcam.Main.main(Main.java:1411)

Any suggestions please??
cheers,
Al

Advertisement



Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 9 guests