Report and discuss bugs here!
Posts: 2
Joined: Thu May 24, 2018 4:19 pm


Postby PaulMes » Thu May 24, 2018 4:23 pm

I use Windows 10 Pro, latest Spring update.
What I found was that as soon as I install Y with JRE10.0.1xx Y stops working.
Removing that 10 JRE environment and replacing it biy the JRE 8.172 version,
brings back the Yamcam cam view.


Posts: 38
Joined: Mon Jul 20, 2015 12:35 pm

Re: JRE10.0.1xx

Postby MA_Angel » Mon May 28, 2018 3:19 pm

Not a YAWcam bug...

Which version Java are you running (i.e., 32 or 64 bit)?

JRE v10 is currently only available for x64, while JRE v8 is available for both x86 and x64?

JRE v10 Downloads:
http://www.oracle.com/technetwork/java/ ... 17026.html

JRE v8 Downloads:
http://www.oracle.com/technetwork/java/ ... 33155.html

Posts: 3
Joined: Tue Jun 05, 2018 12:40 pm

Re: JRE10.0.1xx

Postby dragon » Tue Jun 05, 2018 12:48 pm

Yawcam disappears at "Loading devices..."

YAWCAM - Yet Another Webcam Software
Version: 0.6.1 (2017-12-18)
os.arch: x86
java.home: C:\Program Files (x86)\Java\jre1.8.0_171
java.vendor: Oracle Corporation
java.version: 1.8.0_171
java.io.tmpdir: C:\Users\dragon\AppData\Local\Temp\
user.home: C:\Users\dragon
Max heap memory: 247M
base_path: C:\Users\dragon\.yawcam\
File.separator: \
Local language: en
Time zone: sun.util.calendar.ZoneInfo[id="America/Los_Angeles",offset=-28800000,dstSavings=3600000,useDaylight=true,transitions=185,lastRule=java.util.SimpleTimeZone[id=America/Los_Angeles,offset=-28800000,dstSavings=3600000,useDaylight=true,startYear=0,startMode=3,startMonth=2,startDay=8,startDayOfWeek=1,startTime=7200000,startTimeMode=0,endMode=3,endMonth=10,endDay=1,endDayOfWeek=1,endTime=7200000,endTimeMode=0]]
Reading settings: C:\Users\dragon\.yawcam\yawcam_settings.xml
java.io.FileNotFoundException: C:\Users\dragon\.yawcam\yawcam_settings.xml (The system cannot find the file specified)
at java.io.FileInputStream.open0(Native Method)
at java.io.FileInputStream.open(Unknown Source)
at java.io.FileInputStream.<init>(Unknown Source)
at java.io.FileInputStream.<init>(Unknown Source)
at yawcam.Main.loadSettings(Main.java:691)
at yawcam.Main.<init>(Main.java:236)
at yawcam.Main.main(Main.java:1411)
Could not find: C:\Users\dragon\.yawcam\yawcam_settings.xml
Creating a new: C:\Users\dragon\.yawcam\yawcam_settings.xml
CompatibleImageType: TYPE_INT_RGB (1)
Checking lock file: C:\Users\dragon\.yawcam\yawcam-1.lck
ApplicationInstanceLock: I got ID: 1
Resolving public IP.
url 0 : http://www.yawcam.com/ver.dat
url 1 : http://home.bitcom.se/yawcam_files/ver.dat
Using ip check url: http://www.yawcam.com/ipq.php
Banned ip:
Running init for cam: 0, pin: 0, format: 0
dsj.dll version: 0_8_7
dsj.jar version: 0_8_7
OS: Windows 10, 10.0, x86
JRE: 1.8.0_171, class version: 52.0
Locale: en_US, codepage: Cp1252

java home: C:\Program Files (x86)\Java\jre1.8.0_171

class path: .;lib/activation.jar;lib/commons-jxpath-1.1.jar;lib/commons-logging.jar;lib/commons-logging-api.jar;lib/dsj.jar;lib/monte-cc.jar;lib/mail.jar;lib/mx4j-impl.jar;lib/mx4j-jmx.jar;lib/mx4j-remote.jar;lib/mx4j-tools.jar;lib/sbbi-jmx-1.0.jar;lib/sbbi-upnplib-1.0.4.jar;lib/ftp4j.jar;lib/commons-codec-1.4.jar;lib/turbojpeg.jar

library path: C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Program Files (x86)\Intel\iCLS Client\;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\adb;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Skype\Phone\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Users\dragon\AppData\Local\Microsoft\WindowsApps;C:\Program Files (x86)\OpenVPN\bin;;.
# A fatal error has been detected by the Java Runtime Environment:
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x61014a80, pid=2912, tid=0x00002a24
# JRE version: Java(TM) SE Runtime Environment (8.0_171-b11) (build 1.8.0_171-b11)
# Java VM: Java HotSpot(TM) Client VM (25.171-b11 mixed mode windows-x86 )
# Problematic frame:
# C [dsj.dll+0x14a80]
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
# An error report file with more information is saved as:
# C:\Users\dragon\AppData\Local\Temp\\hs_err_pid2912.log
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

I tried reinstalling, changing directory and whatever else I could think of, except using an older version of Java which I will attempt right now. Please help thanks.

Posts: 2
Joined: Thu May 24, 2018 4:19 pm

Re: JRE10.0.1xx

Postby PaulMes » Sat Jun 09, 2018 7:01 pm


Same issue. JRE updated automatically to 10.XXX. No Yawcam anymore.
Deleted version 10 and repleced it to version 8.X.171/172 and Yawcam worked again.

Strange that Yawcam developper seems to miss this behaviour.

Posts: 3
Joined: Tue Jun 05, 2018 12:40 pm

Re: JRE10.0.1xx

Postby dragon » Mon Jun 11, 2018 5:46 pm

I actually was using Java 8. My problem is still with Java 8, my yawcam is still quitting at "loading devices". Other programs have no problems loading my webcam.

The above dubug info I submitted holds true for java 8,

please help, thanks

Posts: 3
Joined: Tue Jun 05, 2018 12:40 pm

Re: JRE10.0.1xx

Postby dragon » Tue Jun 12, 2018 9:02 pm

I applied latest April Windows update... my problem is no more! Problem fixed! (Java 8)

Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 9 guests