Yawcam won't start after Java upgrade

Questions? Suggestions? Need help? Talk about anything related to Yawcam...
malun
Site Admin
Posts: 1493
Joined: Sun Jan 04, 2004 1:29 pm

Yawcam won't start after Java upgrade

Postby malun » Thu Oct 23, 2014 11:42 pm

Some users report that Yawcam won't start after they updated to Java 1.8.
Yawcam should work with java 1.8, and do so for most users.

If you see the following error messages when you try to start Yawcam, it is probably because something went wrong with the java installation.

jre-error1.png
jre-error1.png (67.78 KiB) Viewed 48411 times

jre-error2.png
jre-error2.png (31.07 KiB) Viewed 48411 times

jre-error3.png
jre-error3.png (87.13 KiB) Viewed 48411 times


The problem
The latest java version doesn't handle coexist or uninstall of the older version correct in some cases. It now tries to run Yawcam with java 1.7 even though java 1.8 is installed and it will stop with the error messages above. To get it all working again you will need to uninstall all java versions and then reinstall the latest version again.

The fix
To uninstall all java versions:
1) Click on the Windows start button and open the Control Panel.
2) Click on 'Programs and Features' to uninstall a program.
3) In the programs list, find all java versions
4) Uninstall them one by one, by right click and select Uninstall

When all java versions are gone, go to http://www.java.com and download and install the latest version.

After this, Yawcam should work again.

Still not working?
If you have followed the steps above and you get a new error message saying "Could not start the application", please follow these instructions:
viewtopic.php?f=4&t=3477

/malun

Advertisement



flossy
Posts: 2
Joined: Mon Oct 27, 2014 2:19 pm

Re: Yawcam won't start after Java upgrade

Postby flossy » Mon Oct 27, 2014 2:27 pm

Hi Malun,

I have the issue that Yawcam wont start , simply says 'could not start the application'

I see nothing obviously wrong , all native Java functions correctly (1.8.0_25b18) i.e. java -version

With a bit of fiddling I can get it to run though , by

- Open a cmd windows , navigate to C:\Program Files\Yawcam>
- Then run the contents of 'launcher.cfg'
i.e. javaw.exe -cp .;lib/activation.jar;lib/commons-jxpath-1.1.jar;lib/commons-logging.jar;lib/commons-logging-api.jar;lib/dsj.jar;lib/jmf.jar;lib/mail.jar;lib/mx4j-impl.jar;lib/mx4j-jmx.jar;lib/mx4j-remote.jar;lib/mx4j-tools.jar;lib/sbbi-jmx-1.0.jar;lib/sbbi-upnplib-1.0.4.jar;lib/ftp4j.jar;lib/commons-codec-1.4.jar -Djava.net.preferIPv4Stack=true -splash:img/splash.gif yawcam.Main


I cant quite figure what is wrong with the environment but running it manually invokes the program , running it via 'yawcam.exe' doesn't

Just in has this helps any

flossy
Posts: 2
Joined: Mon Oct 27, 2014 2:19 pm

Re: Yawcam won't start after Java upgrade

Postby flossy » Mon Oct 27, 2014 4:59 pm

also, running the debug batch file ("C:\Program Files\Yawcam\debug_start.bat") starts the app fine

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Yawcam won't start after Java upgrade

Postby z3r0c00l12 » Thu Oct 30, 2014 12:55 am

Flossy, do you have both 32 and 64 bit java installed? If not, can you install the missing one and try again?

MezzyAna
Posts: 1
Joined: Tue Nov 04, 2014 4:15 pm

Re: Yawcam won't start after Java upgrade

Postby MezzyAna » Tue Nov 04, 2014 4:21 pm

I am having the same problem. Can access it via debug batch file but if I try to open normally I get the 'could not start the application' please reinstall message.

I really like this software and hope there is a workaround to get it functioning again.

BTW: This was a new install (yesterday) on a freshly installed version of Win 7 (64 bit) on a brand new solid state drive with latest java version (have also installed both in case it was that). No old versions to remove.

Any ideas?

Thanks

josefek
Posts: 1
Joined: Tue Nov 04, 2014 7:40 pm

Re: Yawcam won't start after Java upgrade

Postby josefek » Tue Nov 04, 2014 7:42 pm

I'm having the same problem as flossy. I pulled down the offline windows installers for both 32 and 64 bit Java and installed them both.

Siewert
Posts: 4
Joined: Wed Nov 05, 2014 10:15 am

Re: Yawcam won't start after Java upgrade

Postby Siewert » Wed Nov 05, 2014 10:26 am

What happens when you install "Java SE development kit 7" beside Java 8.
With this combination Yawcam works fine over here...

manianvs
Posts: 3
Joined: Sun Nov 09, 2014 6:48 pm

Re: Yawcam won't start after Java upgrade

Postby manianvs » Mon Nov 10, 2014 6:01 am

I am also facing similar problem - Could not start the application
Java is 1.8 version. Path shows clearly java available. So, Java is not a problem.
But no information whether the PC has the direct X or not. While installing, like it checks for java, it does not give any information about Direct X.
Is Direct X necessary?

manianvs
Posts: 3
Joined: Sun Nov 09, 2014 6:48 pm

Re: Yawcam won't start after Java upgrade

Postby manianvs » Tue Nov 11, 2014 5:05 am

For me it is now working but .....
I closed webcam software running in the quick tray & notification area. After I used debug_start.dll. It started the yawcam.
But when I closed yawcam and used from the shortcut, it once again did not start.
The debug_start.dll creates a log and it gives something like this.
-------------------------------------------------------------------
YAWCAM - Yet Another Webcam Software
Version: 0.4.1 (2013-04-18)
os.arch: x86
java.home: C:\Program Files (x86)\Java\jre1.8.0_25
java.vendor: Oracle Corporation
java.version: 1.8.0_25
java.io.tmpdir: C:\Users\Meena\AppData\Local\Temp\
user.home: C:\Users\Meena
Max heap memory: 247M
Max physical memory: 6133M
base_path: C:\Users\Meena\.yawcam\
File.separator: \
Local language: en
Time zone: sun.util.calendar.ZoneInfo[id="Asia/Calcutta",offset=19800000,dstSavings=0,useDaylight=false,transitions=6,lastRule=null]
Reading settings: C:\Users\Meena\.yawcam\yawcam_settings.xml
CompatibleImageType: 1
url: http://www.yawcam.com/ver.dat
url: http://home.bitcom.se/yawcam_files/ver.dat
Resolving public IP.
Using ip check url: http://www.yawcam.com/ipq.php
Passwords:
---------------------------------
---------------------------------
Banned ip:
---------------------------------
---------------------------------
Running init for cam: 1 pin: 0 format: 0
CamManager.initCam()
dsj.dll version: 0_8_7
dsj.jar version: 0_8_7
DSEnvironment.getSystemInfo(true):
OS: Windows 7, 6.1, x86
JRE: 1.8.0_25, class version: 52.0
Locale: en_US, codepage: Cp1252

java home: C:\Program Files (x86)\Java\jre1.8.0_25

class path: .;lib/activation.jar;lib/commons-jxpath-1.1.jar;lib/commons-logging.jar;lib/commons-logging-api.jar;lib/dsj.jar;lib/jmf.jar;lib/mail.jar;lib/mx4j-impl.jar;lib/mx4j-jmx.jar;lib/mx4j-remote.jar;lib/mx4j-tools.jar;lib/sbbi-jmx-1.0.jar;lib/sbbi-upnplib-1.0.4.jar;lib/ftp4j.jar;lib/commons-codec-1.4.jar

library path: C:\ProgramData\Oracle\Java\javapath;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;c:\Program Files(x86)\Java\jre\1.8.0_25\bin;.
CamManager.queryDevices()
F: http://www.yawcam.com/ver.dat
F: http://home.bitcom.se/yawcam_files/ver.dat
0.4.1 == 0.4.1 -> 0
203.199.213.82
Devices:
[0]: Ip Camera
[0]: Ip Camera
[0]: 254 (type)
[1]: iBall Face2Face CHD 12.0 Webcam
[1]: \\?\usb#vid_0c45&pid_62f1&mi_00#6&166ed675&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\global
[1]: 0 (type)
[2]: USB2.0 Camera
[2]: \\?\usb#vid_1e4e&pid_0102&mi_00#6&2735f522&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\global
[2]: 0 (type)
[3]: none
[3]: none
[3]: -1 (type)
Audio Devices:
[0]: Microphone (High Definition Aud
[0]: \\?\hdaudio#func_01&ven_10ec&dev_0889&subsys_80860022&rev_1000#4&24b015d3&0&0201#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\emixedcapturewave
[1]: Microphone (2- USB Microphone)
[1]: \\?\usb#vid_0c45&pid_62f1&mi_02#6&166ed675&0&0002#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\global
[2]: none
[2]: none
INIT CAMERA, SwingUtilities.isEventDispatchThread():false
SwingUtilities.isEventDispatchThread():false
Forcing:
cam=1
pin=0
format=0
..----------------
Initialized:
video: RGB24
width: 640, height: 480
bitDepth: 24
frameRate: 33.333332
duration: 0ms (00:00:00)
----------------
#### Trying RENDERMODE: NATIVE
### RENDERMODE OK! ###
RENDERMODE: NATIVE
Started DeviceMonitor
#######################
Audio output devices:
Primary Sound Driver
Speakers (High Definition Audio Device)
Digital Audio (S/PDIF) (High Definition Audio Device)
Digital Audio (S/PDIF) (High Definition Audio Device)
#######################
Could not load C:\Users\Meena\.yawcam\motion\EventList.xml
(Will create a new one when needed...)
Building device menu right now!
Building 'Change to'-menu...
ICON: 32 bbp: 32
&&&&&&&&&&&&&& PreviewFrame: SwingUtilities.isEventDispatchThread(): true
CU: 1
starting cam
cam started
PreviewFrame: Adding visualComponent!
Building popup menu for preview window.
-----------------------------------------------------------------------------

Do we have to change anything in the regedit?
Shall we have to use only debug_start.dll everytime?
Kindly reply.

rexscuz
Posts: 1
Joined: Fri Nov 21, 2014 4:43 am

Re: Yawcam won't start after Java upgrade

Postby rexscuz » Fri Nov 21, 2014 4:54 am

I am having the same issues after updating to java 8. I un-installed all previous versions and solely installed java 8 and still get the same error messages. I have both versions install of yawcam

control panel.jpg
control panel.jpg (17.96 KiB) Viewed 47111 times
java verify.jpg
java verify.jpg (23.28 KiB) Viewed 47111 times


reg error.jpg
reg error.jpg (13.15 KiB) Viewed 47111 times


It does work fine with the debug start bat file

z3r0c00l12
Moderator
Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Yawcam won't start after Java upgrade

Postby z3r0c00l12 » Wed Dec 03, 2014 4:13 am

Has anyone tried the Java uninstall tool?

https://www.java.com/en/download/help/u ... l_java.xml

Ramsay
Posts: 2
Joined: Sat Oct 19, 2013 6:42 am

Re: Yawcam won't start after Java upgrade

Postby Ramsay » Thu Dec 11, 2014 5:11 pm

flossy wrote:... Yawcam wont start , simply says 'could not start the application'
...
I see nothing obviously wrong , all native Java functions correctly (1.8.0_25b18) i.e. java -version
...


I had the same issue after upgrading jre-7u13 to 8u25 when I removed 7u13 *before* installing 8u25 or when I *allowed* 8u25 to remove the old 7u13version when installing

Only by chance did I find that deliberately having both 7u13 and 8u25 installed would give the first post error

"Error: Registry key 'Software\JavaSoft\Java Runtime Enviroment\CurrentVersion' has value '1.8' but '1.7' is required."

Which could be fixed by removing java 7u13 using the Windows Control Panel Add/Remove programs.

Yawcam would then start normally.

z3r0c00l12 wrote:Has anyone tried the Java uninstall tool?
https://www.java.com/en/download/help/u ... l_java.xml

Yes, it didn't find any out of date versions to remove so didn't change Yawcam's 'could not start the application' message.

Note: I'm currently testing Yawcam BETA 2014-02-10, jre 8u25 and a PS3eye but my stable 24/7 system is using Yawcam 0.3.8 and jre 7u13.

Rico69
Posts: 4
Joined: Wed May 09, 2012 5:48 pm

Re: Yawcam won't start after Java upgrade

Postby Rico69 » Mon Dec 15, 2014 9:19 pm

The Java uninstall\reinstall Worked for me. I did a reboot after I removed Java just to make sure all services where shut down then reinstalled. :D

jxoco
Posts: 40
Joined: Sat Mar 26, 2011 8:50 pm

Re: Yawcam won't start after Java upgrade

Postby jxoco » Fri Feb 13, 2015 6:04 am

my path had something like c:\program data/oracle/java/....
and that was nowhere to be found on my pc.

replacing that with
C:\Program Files\Java\jre1.8.0_31\bin
fixed it.

linokoo
Posts: 40
Joined: Thu Mar 12, 2009 12:07 am

Re: Yawcam won't start after Java upgrade

Postby linokoo » Wed Mar 11, 2015 3:08 pm

Hello,

I had a problem with Java but now Yawcam works.

I installed several times Java & at last Yawcam is ok.

How I made?


The last time, I installed Java 7 and after Java 8.

Follow, I unistalled 7 and miracle Yaw works.

Maybe it could usefull for someone.

Lino


Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests