Problems reading service_profile.cfg

Questions? Suggestions? Need help? Talk about anything related to Yawcam...
bduren
Posts: 9
Joined: Mon Jul 20, 2015 4:03 pm

Problems reading service_profile.cfg

Postby bduren » Sat May 14, 2016 9:40 am

Hello
Thank you for this great application.
In version 6 I have problems letting Yawcam read service_profile.cfg.
When starting it always creates .yawcam in users folder even if I have orther information in service_profile.cfg.

I have been using the old way of starting multiple cameras by adding service to start.bat and using disablerunningcheck.txt.
Using this i think I can start application in any order I want. Cam2 before Cam1 and so on.

What am I missing here? In version 5 I succeded doing like this.

Part of debug log

YAWCAM - Yet Another Webcam Software
Version: 0.6.0 (2016-05-11)
os.arch: x86
java.home: C:\Program Files (x86)\Java\jre1.8.0_91
java.vendor: Oracle Corporation
java.version: 1.8.0_91
java.io.tmpdir: C:\Users\bduren\AppData\Local\Temp\2\
user.home: C:\Users\bduren
Max heap memory: 247M
base_path: C:\Users\bduren\.yawcam\
File.separator: \
Local language: en
Time zone: sun.util.calendar.ZoneInfo[id="Europe/Berlin",offset=3600000,dstSavings=3600000,useDaylight=true,transitions=143,lastRule=java.util.SimpleTimeZone[id=Europe/Berlin,offset=3600000,dstSavings=3600000,useDaylight=true,startYear=0,startMode=2,startMonth=2,startDay=-1,startDayOfWeek=1,startTime=3600000,startTimeMode=2,endMode=2,endMonth=9,endDay=-1,endDayOfWeek=1,endTime=3600000,endTimeMode=2]]
copyFilesToUserDir()
Reading settings: C:\Users\bduren\.yawcam\yawcam_settings.xml
java.io.FileNotFoundException: C:\Users\bduren\.yawcam\yawcam_settings.xml (The system cannot find the file specified)
at java.io.FileInputStream.open0(Native Method)
at java.io.FileInputStream.open(Unknown Source)
at java.io.FileInputStream.<init>(Unknown Source)
at java.io.FileInputStream.<init>(Unknown Source)
at yawcam.Main.loadSettings(Main.java:691)
at yawcam.Main.<init>(Main.java:236)
at yawcam.Main.main(Main.java:1411)
Could not find: C:\Users\bduren\.yawcam\yawcam_settings.xml
Creating a new: C:\Users\bduren\.yawcam\yawcam_settings.xml

Advertisement



malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: Problems reading service_profile.cfg

Postby malun » Sun May 15, 2016 2:45 am

First double check that your start.bat has the word "service" added at the end. It might have been overwritten when you upgraded to version 0.6.0.

Also, one of the news in 0.6.0 is that disablerunningcheck.txt has been removed and replaced with a real option in the settings.
You'll find it here: "Settings -> Edit Settings... -> Startup -> Confirm multiple instances"

/malun

bduren
Posts: 9
Joined: Mon Jul 20, 2015 4:03 pm

Re: Problems reading service_profile.cfg

Postby bduren » Sun May 15, 2016 7:39 am

Of course you were right.
sevice was missing in start.bat.
Thanks

If the first loaded camera has another setting in service_profile.cfg will the next follow i.e creating a filder "2" in the folder service_profile.cfg points to ?

And then be able to use the new functionality ?
/björn

malun
Site Admin
Posts: 1495
Joined: Sun Jan 04, 2004 1:29 pm

Re: Problems reading service_profile.cfg

Postby malun » Mon May 16, 2016 9:36 pm

I'm not sure I understand what you mean here...

But here is an example:

If you install Yawcam to C:\Program Files\Yawcam1
and update the C:\Program Files\Yawcam1\service_profile.cfg to contain:
C:\Yawcam_settings1

When you start the file C:\Program Files\Yawcam1\Yawcam.exe
it will use the settings located in C:\Yawcam_settings1\yawcam_settings.xml

If you start the file C:\Program Files\Yawcam1\Yawcam.exe a second time,
it will use the settings located in C:\Yawcam_settings1\2\yawcam_settings.xml


After this, if you install Yawcam to C:\Program Files\Yawcam2
and update the C:\Program Files\Yawcam2\service_profile.cfg to contain:
C:\Yawcam_settings2

When you start the file C:\Program Files\Yawcam2\Yawcam.exe
it will use the settings located in C:\Yawcam_settings2\yawcam_settings.xml

If you start the file C:\Program Files\Yawcam2\Yawcam.exe a second time,
it will use the settings located in C:\Yawcam_settings2\2\yawcam_settings.xml

/malun

bduren
Posts: 9
Joined: Mon Jul 20, 2015 4:03 pm

Re: Problems reading service_profile.cfg

Postby bduren » Tue May 17, 2016 7:16 pm

Hello
You understood correctly.
Thank you
I will use the "old" setup for handling more cams on the the same machine because it gives me the possibility to start them i any order I want.
I can also have many setups for the same cam in different profiles choosing the setup I prefer for the moment.

/björn


Return to “General”

Who is online

Users browsing this forum: No registered users and 16 guests