Yawcam crashes immediately after startup

Questions? Suggestions? Need help? Talk about anything related to Yawcam...
rjx
Posts: 1
Joined: Fri Dec 02, 2016 1:47 pm

Yawcam crashes immediately after startup

Postby rjx » Fri Dec 02, 2016 2:14 pm

I've been using Yawcam without problems for several years but now its suddenly started crashing on startup.
The console window is displayed briefly but then it disappears.
Its a JRE EXCEPTION_ACCESS_VIOLATION

I've tried rebooting, uninstalling and reinstalling both Yawcam and JRE but it makes no difference.
Netbeans, another program that depends on JRE still works OK.
Yawcam is still working well on a different machine with the same JRE and Win10 versions

The debug log shows:

YAWCAM - Yet Another Webcam Software
Version: 0.6.0 (2016-05-11)
os.arch: amd64
java.home: C:\Program Files\Java\jre1.8.0_111
java.vendor: Oracle Corporation
java.version: 1.8.0_111
java.io.tmpdir: C:\Users\richard\AppData\Local\Temp\
user.home: C:\Users\richard
Max heap memory: 1723M
base_path: C:\Users\richard\.yawcam\
File.separator: \
Local language: en
Time zone: sun.util.calendar.ZoneInfo[id="Europe/London",offset=0,dstSavings=3600000,useDaylight=true,transitions=242,lastRule=java.util.SimpleTimeZone[id=Europe/London,offset=0,dstSavings=3600000,useDaylight=true,startYear=0,startMode=2,startMonth=2,startDay=-1,startDayOfWeek=1,startTime=3600000,startTimeMode=2,endMode=2,endMonth=9,endDay=-1,endDayOfWeek=1,endTime=3600000,endTimeMode=2]]
copyFilesToUserDir()
Reading settings: C:\Users\richard\.yawcam\yawcam_settings.xml
CompatibleImageType: TYPE_INT_RGB (1)
Checking lock file: C:\Users\richard\.yawcam\yawcam-1.lck
ApplicationInstanceLock: I got ID: 1
Resolving public IP.
url 0 : http://www.yawcam.com/ver.dat
url 1 : http://home.bitcom.se/yawcam_files/ver.dat
Passwords:
---------------------------------
---------------------------------
Banned ip:
---------------------------------
---------------------------------
Using ip check url: http://www.yawcam.com/ipq.php
DLL: C:\Program Files (x86)\Yawcam\dsj_x64.dll
Running init for cam: 0, pin: 0, format: 0
CamManager.initCam()
dsj.dll version: 0_8_7 (x64)
dsj.jar version: 0_8_7
DSEnvironment.getSystemInfo(true):
OS: Windows 10, 10.0, amd64
JRE: 1.8.0_111, class version: 52.0
Locale: en_GB, codepage: Cp1252

java home: C:\Program Files\Java\jre1.8.0_111

class path: .;lib/activation.jar;lib/commons-jxpath-1.1.jar;lib/commons-logging.jar;lib/commons-logging-api.jar;lib/dsj.jar;lib/monte-cc.jar;lib/mail.jar;lib/mx4j-impl.jar;lib/mx4j-jmx.jar;lib/mx4j-remote.jar;lib/mx4j-tools.jar;lib/sbbi-jmx-1.0.jar;lib/sbbi-upnplib-1.0.4.jar;lib/ftp4j.jar;lib/commons-codec-1.4.jar;lib/turbojpeg.jar

library path: C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\ImageMagick-7.0.2-Q16;C:\Program Files\ImageMagick-6.9.2-Q16;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Common Files\Acronis\SnapAPI\;C:\Program Files\Calibre2\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files (x86)\Windows Kits\10\Windows Performance Toolkit\;C:\ProgramData\chocolatey\bin;C:\Program Files (x86)\GtkSharp\2.12\bin;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\CMake\bin;C:\Users\richard\AppData\Local\Microsoft\WindowsApps;;.
CamManager.queryDevices()
109.145.66.151
F: http://www.yawcam.com/ver.dat
F: http://home.bitcom.se/yawcam_files/ver.dat
0.6.0 == 0.6.0 -> 0
#
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000061017817, pid=5560, tid=0x0000000000001470
#
# JRE version: Java(TM) SE Runtime Environment (8.0_111-b14) (build 1.8.0_111-b14)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.111-b14 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C [dsj_x64.dll+0x17817]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# An error report file with more information is saved as:
# C:\Users\richard\AppData\Local\Temp\\hs_err_pid5560.log
#
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.


Only thing I can think of that's changed is that I've recently installed Unity with Visual Studio 15 community, and then cmake. It may have stopped working after one or the other install.

Any ideas what might be the problem and how to fix it?

Thanks
Richard

Advertisement



john.gamborg
Posts: 2
Joined: Sun Jan 01, 2017 5:58 am

Re: Yawcam crashes immediately after startup

Postby john.gamborg » Sun Jan 01, 2017 6:07 am

This may be relevant to you, as I'm getting a very similar error message after doing a first time install of Yawcam on my Windows 10 computer today.

I tried applying several fixes related to Java suggested in forums and on Yawcam's Facebook page. None of them worked.

I search online for the specific Java error " EXCEPTION_ACCESS_VIOLATION (0xc0000005)" and one place suggested that it could be related to a graphics card. I'm using a DisplayLink USB adapter to extend my screen to an external monitor. I unplugged it and started Yawcam again and it worked as if nothing had ever been wrong. After setting Yawcam up I connected the USB for the external screen again and it still works fine.

So maybe your error message is not related to Java itself, but another hardware connected to your computer?


Return to “General”

Who is online

Users browsing this forum: No registered users and 7 guests