Yawcam BETA 2004-12-29

Beta versions of Yawcam will be announced in this section. You are also welcome to discuss the beta versions in here.
malun
Site Admin
Posts: 1493
Joined: Sun Jan 04, 2004 1:29 pm

Yawcam BETA 2004-12-29

Postby malun » Wed Dec 29, 2004 12:59 pm

Get the new beta release:
http://www.yawcam.com/beta/yawcam_beta_2004-12-29.zip

What's new since last official release?
- Fixed bug in hidden startup mode. -- ??
- Fixed better error handling for settings file.
- Added offline-image-function.
- Added Time and Data limits.
- Added maximum stream connection limits.
- Added variable stream image production rate.
- Made stream startup robuster on slower computers.
- Fixed a small memory leakage when closing a stream connection.
- Fixed ViewerFrame no-update bug.
- Now ftp uploads tmp-file and rename to correct name.
- Fixed the "String index out of range"-bug for the ftp .

What's new since last beta?
- Made stream startup robuster on slower computers.
- Fixed a small memory leakage when closing a stream connection.
- Fixed ViewerFrame no-update bug.
- Now ftp uploads tmp-file and rename to correct name.
- Fixed the "String index out of range"-bug for the ftp .

Note: This beta includes an attempt to solve the bug that for some users makes Yawcam crash when using the option to start Yawcam hidden to the traybar. If you had this problem before, please let me know if you still get the same error with this beta.

All new functions still only have static language in the beta. Changing the language file will not have any affect.
The sound alert is also static and not possible to disable in this beta release.

/malun

Advertisement



Alex_CH

No frame-update

Postby Alex_CH » Thu Dec 30, 2004 8:31 pm

Hi Malun,

maybe Ive found a bug.

If Yawcam runs for some hours, date and time are updated (overlay) but the picture is an old (no updated frame).

Is this the bug U fixed in this beta:
- Fixed ViewerFrame no-update bug.

Greets from switzerland
Alex

http://www.hobbies-online.ch

malun
Site Admin
Posts: 1493
Joined: Sun Jan 04, 2004 1:29 pm

Postby malun » Fri Dec 31, 2004 1:13 am

The bug you describe sounds like the "freeze-bug", and is not the same as the "ViewerFrame no-update bug".

The "ViewerFrame no-update bug" had to do with the small window that shows a list over the current connected viewers. (Window -> Viewers)

I still don't have found any solution for the "freeze-bug"... :cry:

/malun


Return to “Beta”

Who is online

Users browsing this forum: No registered users and 1 guest