Yawcam doesn't start - Java problem

Questions? Suggestions? Need help? Talk about anything related to Yawcam...
Post Reply
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Yawcam doesn't start - Java problem

Post by malun » Sun Mar 10, 2013 4:18 pm

If Yawcam doesn't start it's possible that something is wrong with your Java installation.

You might get an error dialog looking like this:
Error message when Java problem.
yawcam_no_java.png (11.47 KiB) Viewed 36291 times
It's also possible that the ordinary startup screen is visible for a short period and then nothing more happens.

As a first attempt, please try to un-install and then re-install Java.
You find the latest Java version here:

If you have several versions of Java installed you probably want to un-install all of them before installing the latest version.

If this doesn't help, it's time to check if Java was added to the computer's path variable correctly.
1) Open Windows run dialog by pressing the windows-key and the R-key at the same time
2) Type cmd in the dialog
3) Click OK.
Windows run dialog
windows_run_dialog.png (15.31 KiB) Viewed 36291 times
4) In the command window type:

Code: Select all

java -version
and press the Enter-key.

If Java is present on the path you will get a result similar to this:
Java on the path
java_on_path.png (49.76 KiB) Viewed 36291 times
If you get the message above it's probably not Java that is the cause of your problem and the following steps in this guide will not help you. Try to search the forum for an answer or start a new thread to get some help.

If Java isn't present on the path you will get a result like this:
Java not on path
java_not_on_path.png (50.58 KiB) Viewed 36291 times
Java needs to be added to your path. Follow the steps below.

In some occasions it's also possible to get an error like this:
Java VM init error
java_vm_error.gif (3.19 KiB) Viewed 36280 times
Also in this case it's possible that the path variable needs to b updated. Follow the steps below.

You will need to add Java to your computer's path.
The first step is to locate where Java is installed on your computer. It would typically be installed here: C:\Program Files (x86)\Java\jre7
5) Verify this by open the explorer in Windows and click the folders until you find the Java installation:
Java installation path
java_install_path.png (102.62 KiB) Viewed 36291 times
6) Open the folder named bin and then use the mouse to click in the folder path above to turn it to selectable text.
7) Select the complete path and copy it to the clipboard.
Java path to copy
java_path_to_copy.png (94.8 KiB) Viewed 36291 times
Now it's time to use the path you made a copy of add it to Windows path variable.
8) Open Windows control panel.
9) Click on "System"
10) In Windows 7 and Vista you will need to click on the link "Advanced system settings" to the left to open a dialog called "System properties". (In Windows XP this dialog is opened directly when you click system in the control panel)
11) Click the tab named Advanced
12) You should now see a dialog like this:
Windows system properties
windows_system_properties.png (51.98 KiB) Viewed 36291 times
13) Click the button "Environment variables..." at the bottom.
14) In the dialog that opens find and select "Path" among the systems variables in the lower part:
Windows environment variables
windows_env_vars.png (70.56 KiB) Viewed 36291 times
15) Now click "Edit..." to open a new dialog:
Windows path dialog
windows_path_opened.png (15.03 KiB) Viewed 36291 times
16) Do not replace any of the text in the variable value!
17) Place the marker at the end of the line and add a semicolon ;
18) Right click and paste the path you copied before on the right side of the semicolon
Paste to the right of the semicolon
windows_path_paste.png (32.25 KiB) Viewed 36291 times
19) The path should now look something like this:
Updated path
windows_path_done.png (15.27 KiB) Viewed 36291 times
20) Click the OK button to accept the new path.
21) Click the OK button in the environment variables dialog.
22) Click the OK button in the system properties dialog.

23) Open a new command window again, and see if your computer can find Java. This is done by following step 1 to 4 again. You should now get a result similar to this:
Java on the path
java_on_path.png (49.76 KiB) Viewed 36291 times
24) Now try to start Yawcam again. It should hopefully start:
Yawcam starting
yawcam_starts.png (23.81 KiB) Viewed 36291 times


Posts: 1210
Joined: Wed Jan 14, 2009 3:50 am

Re: Yawcam doesn't start - Java problem

Post by z3r0c00l12 » Sun Mar 10, 2013 4:48 pm

Added this to the useful information thread.

Perhaps we should get a screenshot of the "VM initialization error" and mention that java is not working properly in that case and needs to be re-installed.

Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Re: Yawcam doesn't start - Java problem

Post by malun » Sun Mar 10, 2013 6:01 pm

I made some changes to include the the "VM initialization error".


Posts: 3
Joined: Sun Nov 09, 2014 6:48 pm

Re: Yawcam doesn't start - Java problem

Post by manianvs » Mon Nov 10, 2014 6:07 am

Hi Malun,
I had checked all the above and still find the same error - Could not start the application
Directx 11 is installed in the system.
What should I do?

Posts: 1
Joined: Sun Nov 30, 2014 4:31 am

Re: Yawcam doesn't start - Java problem

Post by digger » Sun Nov 30, 2014 4:49 am

Just wanted to post this here, since the new Java update is throwing something else in the path list and not the ProgramFiles folder.

This did work for me, after spending about an hour wondering why my Windows 8/8.1 (x32 and x64) computers were working, but not Windows 7 (x64).

I had re-installed Java and Yawcam multiple times, and "java -version" even spat out the information for the newest Java I just installed (jre1.8.0_25), but the path was all wrong. Changing it to "C:\Program Files (x86)\Java\jre1.8.0_25\bin" worked.

This is the Java path this update throws in the path list, and no other version of Java have been installed on this computer before (fresh installed OS just today).

Hope this helps some people facing the problem I had.


Path list after installing Java:

Code: Select all

C:\ProgramData\Oracle\Java\javapath;  <-- What Java update throws in
C:\Program Files\Intel\WiFi\bin\;
C:\Program Files\Common Files\Intel\WirelessCommon\

Posts: 5
Joined: Sat Mar 16, 2013 1:40 pm

Re: Yawcam doesn't start - Java problem

Post by ap_ » Mon Jan 05, 2015 11:33 pm


your tip saved my day. Thx very much.

Switched from XP to Windows7/64bit. Was already about to throw yawcam away and try something else when i found your tip.

But: Got many strange errors, i.e. when stopping yawcam the exitwindow was stuck (had to kill javaw.exe alway with pskill).
Changing the language and then trying to edit the settings ended up with yawcam asking for the folder where the default.xml
for the languag was located. But even when choosen crashed then.

At last i tried to change the (java-)path to "C:\Program Files\Java\jre1.8.0_25\bin" instead of "C:\Program Files (x86)\Java\jre1.8.0_25\bin"
(i had both, 32- and 64bit javas installed).

That did the trick, yawcam works now like it should.

Posts: 18
Joined: Wed Aug 08, 2012 11:49 am

Re: Yawcam doesn't start - Java problem

Post by Basara » Tue Apr 21, 2015 2:43 pm

Just to say I have just reinstalled Yawcam 0.4.1 on Win 7 x64 and ran into this problem.

If i tried to run Yawcam I would be faced with the "Open With" dialog and it asking me what program I wanted to run "javaw.exe" with.

Java version is now 1.8.0_45 and i have both x32 and x64 java installs

Removing "C:\ProgramData\Oracle\Java\javapath;" from the very start of my system enviroment variables fixed the issue immediately \o/

Posts: 2
Joined: Tue Apr 30, 2013 6:22 pm

My problem caused by Win 7 Java Symlink Failure *FIXED*

Post by mbunds » Sat May 09, 2015 5:24 pm

I had a problem getting Yawcam to start on Windows 7 64-bit, where clicking on the Yawcam shortcut on the desktop (or even "Yawcam.exe" in its install folder) where Yawcam failed to launch but instead Windows presented a dialog box "Choose the program you wish to use to open this file", also displaying "Javaw.exe" as the program that could not find its resources.

I went about all the usual "create environment paths, uninstall/re-install Java 64/32 bit multiple times, check registry associations, and all that crap for hours, but Yawcam would not launch.

Stupidly, I used the dialog box "Browse" button and went to the Java installation folder and chose "Javaw.exe" as the program to open. DO NOT DO THIS as it will destroy all of your file associations in all shortcuts and YOU WILL NOT BE ABLE TO LAUNCH ANY PROGRAMS, THE COMMAND PROMPT, OR REGEDIT until you restore the registry defaults for .lnk associations. After I did this all my shortcut icons changed to the Java icon, and nothing would launch until I fixed the registry.

It turned out that the fix was exceedingly simple (and I would have stumbled upon it much sooner if I had bothered to read these forums.)

Anyway, an hour later after my file associations were repaired, I read through these forums and learned to launch "debug_start" from the Yawcam folder, which produced the yawcam_debug_log.txt file saying "The system cannot find the file C:\ProgramData\Oracle\Java\javapath\java.exe."

The path "C:\ProgramData\Oracle\Java\javapath" contains "SymLinks," and for typical Windows crap reasons, they failed to function when executed from explorer, so I replaced them with regular shortcuts, and Yawcam launched normally. Be advised that symlinks exist for a reason (that escapes me), so applying this fix may get Yawcam to launch, but who knows what else I may have broken, however, I did this EXACT SAME PROCEDURE before I upgraded to WIn 7 Ultimate on this computer, including screwing-up my file associations (you'd think I would have learned), and everything Java seemed to be fine for more than a year.

(See "http://superuser.com/questions/304093/e ... -not-exist" for more information about typically convoluted Windows screw-ups regarding symlinks, and most interestingly, this entry describes a symptom many Yawcam users experience troubleshooting launch issues where Yawcam won't launch from the desktop shortcut, but will from the command prompt). Have fun sorting that out, but as for me I am happy to have Yawcam working again.


Post Reply