Yawcam 0.5.0 RELEASED!

Questions? Suggestions? Need help? Talk about anything related to Yawcam...
malun
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Yawcam 0.5.0 RELEASED!

Post by malun » Mon Feb 01, 2016 1:17 am

Yawcam 0.5.0 has been released!

What's new?
- Fixed problem with repeated images when device wakes up after sleep.
- Fixed extravars text overlay for empty files.
- Fixed correct action on cancel button for IP camera settings.
- Fixed the broken limit function for motion detection actions.
- Fixed performance problem when the Motion Event list is very long.
- Fixed possible memory leak when previewing Motion Events.
- Fixed window position when previewing Motion Events.
- Fixed image width/height ratio in Motion Events' mini preview.
- Fixed e-mail smtp port number problem in SSL mode.
- Fixed the 2GB file size limit for "Images to Movie".
- Fixed broken page preview.
- Fixed compatibility issues with Java 9.
- Added default URL if version check fails.
- Added auto sensitivity/tolerance for motion detection.
- Added new algorithm for motion detection.
- Added max filter for motion detection.
- Added noise filter for motion detection.
- Added popup menu with image size for motion detection.
- Added video recorder for motion detection.
- Added auto delete for motion detection's event list.
- Added option to show Preview Window without borders.
- Added functionality to move Preview Window with mouse dragging.
- Added support for running multiple instances of Yawcam.
- Improved JPEG encoding performance.
- Removed the Java Applet.
- Updated language files.

Get the latest version here:
http://www.yawcam.com/download.php

/malun

Advertisement



duckietm
Posts: 4
Joined: Fri Oct 12, 2012 7:57 am

Re: Yawcam 0.5.0 RELEASED!

Post by duckietm » Wed Feb 03, 2016 8:57 am

Excelent release Thanks !

amoeba
Posts: 1
Joined: Wed Feb 03, 2016 11:18 am

Re: Yawcam 0.5.0 RELEASED!

Post by amoeba » Wed Feb 03, 2016 11:32 am

Look dude,

Every time I turn on Yawcam, and it tells me there's a new release, it's like Christmas for me.
I really use Yawcam daily, and when there's new feats, it's just AMAZING.

THANKS for your hard work.
Sincerely from a fan.

malun
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Re: Yawcam 0.5.0 RELEASED!

Post by malun » Wed Feb 03, 2016 11:42 pm

Thanks for the kind words!

/malun

theoriginalrage
Posts: 3
Joined: Tue Aug 18, 2015 4:30 am

Re: Yawcam 0.5.0 RELEASED!

Post by theoriginalrage » Fri Feb 05, 2016 8:37 pm

Absolutely love YAWCAM but 5.0 killed my stream and I'm not sure why. It says I'm online but when I go to my page it's saying it's offline. Any thoughts?
Also I just noticed that I can't open the preview window.

malun
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Re: Yawcam 0.5.0 RELEASED!

Post by malun » Fri Feb 05, 2016 9:11 pm

Strange! Do you get the same behavior if you restart Yawcam?
...or the next step, if you restart your computer?

/malun

theoriginalrage
Posts: 3
Joined: Tue Aug 18, 2015 4:30 am

Re: Yawcam 0.5.0 RELEASED!

Post by theoriginalrage » Sat Feb 06, 2016 5:07 am

I uninstalled, and re-installed and it is working again. Not sure what the issue was with the update but I'm up and running again.
Thanks for the awesome program!

fchiesa
Posts: 1
Joined: Sat Feb 06, 2016 8:34 am

Re: Yawcam 0.5.0 RELEASED!

Post by fchiesa » Sat Feb 06, 2016 8:40 am

Hello Malun and thanks for the continued support on this software.

I need to use multiple instances of the software, each with its own configuration (camera, streaming port, etc). I have seen that the last 0.5.0 version mentions a support for multiple instances but there is no detail on how to make it work.

For me (Java developer too), would be enough to have a command line option in order to indicate whici is the .yawcam directory to use, as it is clear that all settings are there, in the %USERHOME% directory.

Can you please give more insight on how to run multiple instances, each pointing at a separate configuration?

Thank you in advance.

Federico

malun
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Re: Yawcam 0.5.0 RELEASED!

Post by malun » Sat Feb 06, 2016 5:40 pm

As you pointed out, the settings are stored in the ".yawcam" folder in the %USERPROFILE% directory.
This typically resolves to C:\Users\username\.yawcam

The new support for multiple instances of Yawcam works like this:

First instance you start will store all settings and user files directly under the %USERPROFILE%\.yawcam folder.
Run Yawcam's start file again, and you will get a question if you want to start another instance.
If you agree to do so, the settings for the second instance will be stored in the folder %USERPROFILE%\.yawcam\2
When you start a third instance the settings will be stored in the folder %USERPROFILE%\.yawcam\3

This means that you don't need to manually point out the settings. Yawcam will automatically create and use the settings according to how many instances you are running. Just run Yawcam's start file multiple times.

However, Please note that Yawcam will use the default settings when they are created. So if you for example plan to enable stream output on two instances you will have to change the port number on the second instance. Otherwise the port will be occupied by the first instance.

/malun

bduren
Posts: 10
Joined: Mon Jul 20, 2015 4:03 pm

Re: Yawcam 0.5.0 RELEASED!

Post by bduren » Sat Feb 06, 2016 5:57 pm

Hello
This is how I did it. (I see now that malun has made it more easy in later versions)

Install yawcam in d:\cams\yawcam1
In the yacamfolder edit the file start.bat and add service at the end of the line like Main service.
Edit service_profile.cfg so it points to d:\cams\yawcamsettings\yawcam1
Create folder d:\cams\yawcamsettings\yawcam1

When you start yawcam.exe from c:\cams\yawcam1 it creates a folder in d:\cams\yawcamsettings\yawcam1 called ".yawcam"
Create an empty file called disablerunningcheck.txt in that .yawcam folder.

Copy the installation folder to d:\cam\yawcam2 or as many as you want and edit service_profile.cfg in each pointing to the correct folder.

Three important things.
1. service at the end of line in start.bat
2. service_profile.cfg points to correct yawcamsettings folder.
3. an existing empty disablerunningscheck.txt in each .yawcam folder.

/bjorn

PS. I have been running 6 cams, IP and USB cams, before the CPU gave up. File, Http and Motion. Streaming so many cams is no possible with quality.

malun
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Re: Yawcam 0.5.0 RELEASED!

Post by malun » Sat Feb 06, 2016 7:39 pm

Yes, the procedure bduren describes was used before version 0.5.0.
And the procedure I described in my last post can be used from now on.

However, even in 0.5.0 you can still use the "text file hack" of disablerunningcheck.txt to avoid having to confirm that you want to start a new instance.
More info about text file hacks here: http://www.yawcam.com/forum/viewtopic.php?f=4&t=1264

/malun

LordJair
Posts: 1
Joined: Sun Feb 07, 2016 6:43 am

Re: Yawcam 0.5.0 RELEASED!

Post by LordJair » Sun Feb 07, 2016 6:58 am

I'm having trouble getting the service to start. It installs fine and is listed in the Services listing. However, when I try to start it, it remains stuck on "Starting" in the status column. I've uninstalled/reinstalled, removed the .yawcam folder and repeated the un-/reinstall, I've changed accounts under which the service starts, and, well, anything I can think of. Just earlier on the day I installed 0.5.0, the service ran fine with 0.4.x (whatever the immediately previous build).

I even added the word "service" to the end of the start.bat line — both with and without the word "start" before it.

Can anyone help a frustrated man out? :) Thanks!

Win 10 Pro 64-bit

-LordJair

GreyOwl
Posts: 6
Joined: Tue Jan 05, 2010 8:02 pm

Re: Yawcam 0.5.0 RELEASED!

Post by GreyOwl » Mon Feb 08, 2016 10:38 pm

My computer just updated Java last night all on it's own and now I can't even start Yawcam. I don't know if it is just a coincidence or not. I went ahead and renamed my Yawcan to OldYawcan then downloaded version 5.0 and still am unable to open Yawcam.
Any help would be appreciated.

MA_Angel
Posts: 41
Joined: Mon Jul 20, 2015 12:35 pm

Re: Yawcam 0.5.0 RELEASED!

Post by MA_Angel » Thu Feb 11, 2016 1:09 am

If your PC is running Windows XP, then read the following post for guidance:

http://www.yawcam.com/forum/viewtopic.p ... 528#p12472

Otherwise, try uninstalling Yawcam plus all instances of Java, and reboot PC. Then perform a fresh install of the latest version of Java first, and follow by a fresh install of Yawcam 0.5.0.

malun
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Re: Yawcam 0.5.0 RELEASED!

Post by malun » Thu Feb 11, 2016 9:16 pm

@LordJair

There is probably a mix-up between 64 bit and 32 bit versions of the service and Java.
Since you have a 64 bit machine, the service was installed as a 64 bit service. Sadly the 64 bit service won't start if you only have a 32 bit java installed.

Please install a 64 bit java and try again. That will hopefully get the service running.

You find the 64 bit java on this page:
http://www.java.com/en/download/manual.jsp

It's called: Windows Offline (64-bit)

/malun

Post Reply