Page 2 of 3

Nice utility

Posted: Thu Oct 21, 2004 7:37 pm
by Johnny Ringo
I do not know if you are taking enhancement suggestions, but I use the Yawviewer to host Yawcam and it works very well, but it seems to be missing the ability to capture a screen shot of the current image in Yawcam. Of course it's always easier to ask for something when you don't have to do it, but this feature would make my job of mocking my friends so much easier. tia :wink:


Posted: Thu Oct 21, 2004 7:47 pm
by Johnny Ringo
Sorry, all, this is the last post I'll make! I submitted (obviously) too many times because of odd error messages. If i had a screen print feature, I'd make a copy of my contrite face and post it for all to view and pity.

J. Ringo!

Posted: Thu Oct 21, 2004 7:52 pm
by malun
No, problem. I just removed the duplicated messages.
There seems to be some problems with my smtp server right now causing these terrible error messages when you post a message.

But your post will show up even if you get an error message.

Hope this gets back to normal soon...


newest features

Posted: Thu Oct 21, 2004 8:33 pm
by jolivo
Sleek graphical buttons in the latest version...

Yawviewer's simplified interface offers buttons to open/close the control panel, pin the interface to be "always on top" of other windows, refresh the Yawcam, and navigate to web sites for information & updates.


Posted: Sun Oct 24, 2004 5:37 pm
by malun
I have just added a link to the yawviewer homepage from the download page...


Posted: Fri Nov 05, 2004 10:55 pm
by Guest (Ryan)
OK i have the program, however it doesent seem to work on laptop.
It just gives the gray java box. like its about to work.

if i put an incorrect IP, it gives the red X so it seems mostly ok, any issues known?

Posted: Fri Nov 05, 2004 11:11 pm
by Guest (Ryan)
ok more info, it works with web browser on laptop, and with the viewer, after a min or 2, the java icon turns to a red X as well

Posted: Sun Nov 07, 2004 10:34 pm
by malun
I suggest that you send a mail to the creator of Yawviewer.
Jesse Olivo:


java icon turns to a red X

Posted: Thu Nov 11, 2004 6:44 pm
by jolivo
Ryan's issue sounds like there may be a problem with his laptop's Java Virtual Machine, considering it is the Java icon itself that is turning into a red X (the red X in place of the Yawcam applet indicates the same).

:arrow: Sun Microsystems discusses a solution to this problem in an article entitled "Red X image displayed where the applet should be, applets won't run" (

I hope the article helps. If not, here are some support links...

...for Microsoft's Java Virtual Machine:
...and Sun Microsystem's Java Virtual Machine:

If this solution works, let us know. :)

Version 1.1.0 available!

Posted: Mon Dec 06, 2004 11:45 pm
by jolivo

:idea: Snapshot/image capture
:idea: Embedded image viewer (open/save picture files)

:arrow: ... iewer.html

Version 1.2.0 is available for download

Posted: Wed Feb 16, 2005 7:33 pm
by jolivo
The latest version of Yawviewer includes a resize feature that supports multiple display modes:


Other improvements:

:idea: Last display mode used is recalled when starting up.
:idea: Yawcam connection control panel is now a menu.
:idea: Consolidated information links into one menu.
:idea: Yawviewer never shows up in taskbar (only in systray).
:idea: Snapshot functionality is only available when a Yawcam is selected.

:arrow: ... iewer.html

Re: tried it - explorer won't open, have to reinstall window

Posted: Tue Jul 19, 2005 10:31 pm
by Guest
loz wrote:just a note to anyone trying this Yawviewer. I don't know what exactly went wrong but when I tried to install this viewer I got a message that it couldn't be installed because some of my files were out of date & would I like to update them. I (stupidly, as it turned out) said 'ok' to that & was given the message that windows had to restart, that the install wasn't complete and that the temporary install files wouldn't be deleted from my drive during restart. I did allow windows to restart, after which I got/get this message: "explorer.exe cannot open. you will have to reinstall windows'. when I clicked OK to that (my only option), I got/get this message: 'error starting program: The msvcrt.dll file is linked to missing export NTDLL.DLL:RtlGetNTVersionNumbers'.

so, I cannot use that hard drive until I manage to get around this somehow. I can't boot into safe mode even, to try to uninstall the program or stop whatever's in my start up folder from this program. I'm hoping that at worst I can reinstall windows over the current folder & get rid of that biz, without having to wipe *everything* from my hard drive (which is a new one finally set up how I need it after about a month of using it & reinstalling all my progs, hardware, etc). and so on.

so, I don't know what it was about this program that caused the problem, but I suggest to anyone who tries it NOT to update their files if the program gives you this message. or, maybe don't even try it until the programmer fixes whatever it might be that screwed my hard drive, in case it's not just something specific to the way it worked with my own system &/or the way I installed the program. thing is, everything was quite normal... it all happened after I said okay to updating the older files, and that was definitely all part of this program's install. I should've just said NO & not bothered installing it at all. but who'd have thunk it'd turn out like this? never had any problem like this, before.

I'm just sooooo glad I didn't get rid of my old hd or reformat it as a storage drive only - at least I'm still able to boot into it (which is how I can be here mentioning the problem a.s.a.p.) & hopefully save the other drive from having to be reformatted & wiped completely with a new windows install.

I'm not sure if I'll get it fixed immediately or not, but in the meantime if anyone has any advice about getting around those messages (the ones I'm getting on re-boot, that say windows has to be reinstalled & about the missing export DLL) somehow so I can still use the drive without reformatting, please post... I'll check back here for thoughts too, if I'm not having any luck.

*sigh* man, I don't have TIME for this shit. always happens when you have the least amount of available time for it, eh?

Re: Installation fix

Posted: Wed Jul 20, 2005 2:04 pm
by jolivo
:arrow: Sorry someone has run into this old problem, but verison 1.0.2 should no longer be available. Please install the latest version ( ... iewer.html) which should not cause this problem.

Here is the original reply to Loz's issue:
jolivo wrote::!: There is a Microsoft Knowledge Base Article (#330314) that addresses the problem described above, entitled "PRB: Your Computer Does Not Restart After You Install a Microsoft Visual Basic 6.0 Application That Includes a MSVCRT.dll File": ... -us;330314

It includes a resolution section for NT/98 and an installation fix, which I've applied to a new installation: ...

I have removed the problem installation and repeat loz's/Microsoft's advice: Do not update the msvcrt.dll file during an installation.

I am truly sorry this problem was encountered and hope any affected systems recover fully.
And here is Loz's original reply:
loz wrote:jolivo, I can't thank you enough - you've just saved me likely 4 million hours (okay, a slight exaggeration, but still) of searching for the right fix.

I'm back to normal, using my hd as I was prior to install, with a simple copy file operation in DOS... too cool!

thank you VERY much for the help! (and doesn't it just figure this would be a bloody microsoft issue?)

anyway, again, thank you... all's well in my world - and my computer - again :).

Hope you have the same luck! :)

Yawviewer available via email

Posted: Wed Jul 12, 2006 9:08 pm
by jolivo
:!: As I am in the process of changing my internet service provider, Yawviewer will not have a home page for the foreseeable future.

But I will gladly e-mail the latest version of Yawviewer to anyone who requests it at

Sorry for the inconvenience. :(

New home for Yawviewer

Posted: Wed Jul 18, 2007 3:05 pm
by jolivo
The new home page for Yawviewer is here:

Get the latest version of Yawviewer there.

- Jesse